Showing results for 
Search instead for 
Did you mean: 

VM Connect App and Router access

Tuning in

Good afternoon

A couple of weeks ago I had to have my electricity meter replaced which meant the power was off for a while. Since then I have been unable to use the VM Connect app as it keeps saying it can't find the hub. I also can't log into the hub GUI at, it asks for my password but then displays a blank screen. It does this from my windows PC and also my iPhone and iPad so it looks like a hub issue.

I have tried a restart of the hub a couple of times but then suffer poor WiFi for hours afterwards while it sorts itself out and reconnects to my wifi pods. I also did a full factory reset but it still will not connect to the app or through the GUI.

The WiFi and direct connection via Ethernet all seem to be OK apart from it being very slow after the reset. Could this be the Hub failing (Hub 4)?

Can anyone suggest a way to resolve this or do I have to give up my Saturday morning on the phone to customer services?


Joining in

Good Evening,

I'm having the same issue with my hub 4. It's been like it throughout this week. When I try and sign into the hub I just get a white screen and after a bit of time it returns to the log in screen. The VM connect app isn't working for me either it says i't can't find the hub.

It's becoming quite frustrating.

Hi @MorbidRobbo 👋.

Thanks for reaching out to us, apologies for the delay in responding, we are currently aware of the connect app not finding the Hub 4 and we are in the process of getting that fixed for those affected. Apologies again.


I have this issue with hub 4 & vm connect app. Had new hub & engineer out. Disconnected cables, reconnected, done reset & uninstalled & reinstalled app. Still can not connect to hub 4 with app.

Hey Zee36, thank you for reaching out and I am sorry to hear this. 

I would delete the app and reinstall it under the new hub this should fix this for you. 

Matt - Forum Team

New around here?

I am jumping on this post since I have the same problem. I have been a Virgin customer for, hmm, 2 days. 

My Hub was connected at approx 5pm on Thursday 21st March. I logged in to it once, after the engineer left, when I was prompted to and so changed my password. I have not been able to log in to it since. I get the blank white page in whichever browser or device I'm using. 

My App does not connect. 

Considering this is a 'known problem' I find it disgraceful that Virgin are still issuing this faulty kit to new customers.

Is there a solution yet?

Hi there @Spannerman1 

We are so sorry that you have also faced this issue and thank you do much for posting to the community forums, it's great to have you here. 

Have you been able to try the steps previosuly mentioned in this thread? 

Yes, and like everyone else, I cannot log in, the VM App says Hub Not Found.

After resetting it countless times, I get the Welcome page where I choose my language, have the option to reset the password, then the blank white PAGE OF DEATH.

I tried this when my engineer left on Thursday after installing my connection and Kit. I have NEVER been able to log in to this Hub 4 router. 

I find it disgraceful that Virgin know there's a problem but still issue non-working kit to a brand new customer. It does not instil me with any confidence in Virgin at all.

How do I request a replacement Hub? Might as well try that.

2 more days past and no contact from Virgin.

I have just PM's one of the team who replied to this thread, let's see what happens.  

Hi there @Spannerman1 

We do not reply to unsolicited PM's but if we need to take the conversation into a private message then we will pop one across. 

Can you confirm the steps you have taken so far, have you tried uninstalling and reinstalling the app as well as full pin hole reset on the Hub? 

When you say you cannot access the Hub do you mean you are unable to access the Hub setting page after entering on the address bar of your browser?