Showing results for 
Search instead for 
Did you mean: 

App won't let me use any password I chose when setting up account

Tuning in

Hi guys 

Setting up my account on the app, everyone I try to set a password it says I can't use that password, I've between 30-40 different passwords with no joy 


Hi yeh I have Tried over 40 different passwords on 3 different bbrowsers and still nothing 😞


Hi @Jayv89, thanks for your post although I'm sorry that this is still unresolved for you.

We may need to get an IT Ticket raised for you to resolve this, but I can see you're in contact with Kain via PM so he should be able to raise one for you in due course.

Please allow him to respond directly when he is back in the office and we can take it from there.

Many thanks


Tuning in

I’m having the same problem

Hi there @Kh11


I'm so sorry to hear that you are also facing this issue with your password! 


I'll pop you a PM now so we can take a look, please keep an eye out for the purple envelope in the top right corner of your screen alerting you to a new message. 


Thank you. 

Hello there,

Reposting advice from a different thread that helped me and several other users avoid this problem.

Please use a dummy password such as 'abcabc11' to log in - the system should allow it - then change it to something more sensible.

Joining in

I am having this issue and no matter what has been suggested above no passwords will work

Not applicable

Exactly the same issue. Increadibly frustrating. Tried multiple devices with different browsers. Cannot get it to accept a password. Now when I try to create an account on my fire tablet it says there is already an account registered with this email, so I ask for a password reset and it says there is no account for that email!

Just joined and set up and now really effing angry at this absurd system. It's clearly an issue for loads of people. Why? 

Worked using dummy password indicated

I have exactly the same problem, no matter how many passwords I try, nothing works. Virgin Media, help?

Not applicable

I tried the dummy password, it didn't work.