Showing results for 
Search instead for 
Did you mean: 

Virgin Media Hub 5 Blocking Slack Application

Joining in

Hi All,

Since Monday for some reson my Virgin Media will not let me connect to anything 'Slack' related. This includes the website, mobile app, and desktop asp. I use Slack for work so its become a real pain. 

I have tried using the same laptop on a different WiFi network (Coffee Shop) and Slack opens and runs perfectly, It even works perfectly if I hotspot from my mobile phone - however as soon as I connect back to my home WiFi the page fails to load and the application cannot connect. 

I have tried to contact Virgin but they havent been able to fix the issue. I have also turned my router off, reset it etc. all of which do not work. 

The issue is 100% with my home network, either blocking something or not allowing Slack to connect. Which is strange as historically its worked fine. 

I also do not have a VPN or Firewalls etc. connected. 

Any help would be great. 


Dialled in


They are aware of this and are apparently fixing it :

Are you anywhere near the WA4 postcode by any chance as this seems to be a common factor at the moment for affected users.


Hi Paul, 

Thanks for the response, I am located within the WA4 post code also. 

Wonder if there is a time scale on them fixing this issue....probably not. 

Thanks for the insight. 


Joining in

I just received the below response on the issue from the guys at Slack...

I believe I have spotted the culprit. It seems that there might be a misconfiguration or issue with the DNS resolution process. The log you provided indicates that the DNS query for the domain "" was successful, and it returned four IP addresses. However, when attempting to establish a socket connection to one of these IP addresses, it connects to the address "" on port 53, which is typically associated with DNS. Slack connections are established over port 443.

This behavior suggests that there might be an issue with the DNS resolution or with the way the IP address is being used. It's possible that there's a misconfiguration in the network settings.

If this doesn't work, then there's something else on the way your network is set up that's causing this. You'll need to reach out to your Internet Provider for further assistance on this as we cannot troubleshoot their network.

Dialled in


I think the guy at Slack is reading your log files incorrectly. Your machine making a connection to on port 53 is simply your machine making a DNS request. The default DNS servers for VM are and so that behaviour is perfectly normal.