Showing results for 
Search instead for 
Did you mean: 

Hub 3 doesn’t install on connect app

Joining in


Having problems connecting the Hub 3 to the connect app,

Reset Hub etc etc. and getting nowhere.

Any suggestions?


Forum Team (Retired)
Forum Team (Retired)

Hi LRodge,

Thanks for your post and welcome to the community.

Apologies for the issues faced with the Connect app, firstly have you been able to connect previously?

Also are any error codes appearing?

Have you tried on different devices and re-installing the app etc?

Let us know,


Tuning in

Not sure how to fix this tried reset etc

No haven't been able to connect before, only have my mobile device to connect from.

No error code

The VM Connect app is the issue, it may take a few days to work.

Don't reset or restart the Hub 3, the Hub is not the problem.

If you need to manage the Hub now, connect to it at


Still doesn't connect. How do we resolve this??

Hi Ladybug 1976, 👋  sorry to hear you are still having issues getting your hub to connect to the connect app.

Can we check a few more things for troubleshooting;

- Is your phone software up to date with the latest operating system?

- Is this happening on an apple or android device? 

- Have you checked for any software updates on the app?

- What were you trying to use the connect app for, so we can offer further support with this if needed?

Let us know and we can offer some more help! Thank you for your patience in the meantime, I appreciate these kinds of issues can be frustrating. 

All the best. 🌞