Menu
Reply
Highlighted
  • 8
  • 0
  • 4
triedandtested
Tuning in
624 Views
Message 1 of 27
Flag for a moderator

Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Hello all...

Am really hoping some kind and helpful person can help me as I'm at a loss as what to do next with this issue and am getting perilously close to imploding what with being passed back and forth between Hostgator and Virgin Media 'support' reps continuously for the past 6 days!

I have several email addresses that have been set up through my Hostgator-hosted websites (Domains are @funnymatters.co.uk, @brightonfoodtours.com + @brightwellcreative.co.uk). For the past 6 days suddenly none of these Hostgator email addresses have been receiving or sending emails on any device when connected via my home VM wifi network. When I connect my devices to my mobile network or a different wifi network, all email addresses function normally. Strangely I seem to have the same problem with accessing my Hostgator cpanel: gator3042.hostgator.com (it says the server where the page is located isn't responding). Yet, I AM able to load the actual websites themselves, which seems strange. All other non-Hostgator emails are working fine on the home VM wifi network. 

I have now been in touch with Hostgator support at least 10 different times, and here's a selection of what they've reported back - all of which have resulted in no resolution:

"It is on the incorrect MX record and Email Routing. Your email routing is not set to Local. I change it for you. You need to wait for 4-8 hours for the MX records to propagate to get it work" 

"I am not seeing that IP address being blocked by anything on our end. You will need to contact your ISP. Everything for the domain names related to their DNS is setup correctly. Please contact your ISP, there is no issue from our server end. I am not seeing that IP address you provided me on a blacklist or a block list"

"I am currently checking the dovecot files for funnymatters.co.uk at the moment. Our server is not blocking. I am not seeing the connection denied in the dovecot files."

The most recent contact with Hostgator talked me through running a traceroute in my terminal application (I'm on a Mac) for funnymatters.co.uk and the result is below (at the foot of this post). It all means pretty much nothing to me so I have no idea whether it indicates the fault is with Hostgator or with VM (or elsewhere). The Hostgator support person who I sent the below traceroute to, was still adamant that it was a VM problem: "You hovering over and around 200MS. hops that are greater then 200MS or return the asterisks *** indicates that the request has timed out. This is an issue with their ISP and their services timing out when connecting with the Hostgator server. You will need to contact their ISP to look further into this for you. Your computer's IP address does not appear to be listed on a RBL or in our internal apache/exim blacklist; your IP address is not blocked in the exim blacklist."

Yet when I contacted Virgin Media they say it is  not their issue and that "the connection is fine from the router and we've not blocked any of your emails or server related to emails."

My question is - does anyone know what the problem might be and can decipher the below traceroute? And, is it a Hostgator issue, A VM issue, or something else? If I have more of an idea of whose responsibility it falls under I can then go back to them and 'try' to escalate it somehow but at the moment I don't know which way to turn and am utterly clueless and at a loss what to do next.... 

Thanks to anyone who can offer any help to a desperate woman! (And apologies for my lack of knowledge and general tech ignorance btw)

Here's the Traceroute I ran:

traceLast login: Sat Jul 28 16:51:39 on console
Angelas-MacBook-Air:~ Angela$ traceroute funnymatters.co.uk
traceroute to funnymatters.co.uk (192.232.219.195), 64 hops max, 52 byte packets
1 192.168.0.1 (192.168.0.1) 3.655 ms 3.457 ms 2.702 ms
2 * * *
3 brig-core-2b-xe-805-0.network.virginmedia.net (80.3.64.105) 12.310 ms 39.634 ms 11.137 ms
4 * * *
5 * * *
6 m674-mp2.cvx1-b.lis.dial.ntli.net (62.254.42.162) 25.398 ms 29.527 ms 33.848 ms
7 nl-ams17b-rc1-lag-5-0.aorta.net (84.116.134.53) 25.247 ms
nl-ams02a-rc2-lag-30-0.aorta.net (84.116.130.125) 28.214 ms 25.928 ms
8 nl-ams09b-ri1-ae5-0.aorta.net (84.116.134.54) 28.602 ms
nl-ams09b-ri1-ae32-0.aorta.net (84.116.130.178) 27.009 ms
nl-ams09b-ri1-ae31-0.aorta.net (84.116.130.150) 25.111 ms
9 213.46.182.254 (213.46.182.254) 25.223 ms 26.091 ms 26.094 ms
10 ae-19.r25.amstnl02.nl.bb.gin.ntt.net (129.250.2.178) 26.906 ms 25.843 ms 26.942 ms
11 ae-5.r23.asbnva02.us.bb.gin.ntt.net (129.250.6.162) 115.143 ms 124.273 ms 123.342 ms
12 ae-10.r22.snjsca04.us.bb.gin.ntt.net (129.250.6.237) 190.336 ms 177.201 ms 182.995 ms
13 ae-19.r01.snjsca04.us.bb.gin.ntt.net (129.250.3.27) 188.232 ms 176.137 ms
ae-40.r02.snjsca04.us.bb.gin.ntt.net (129.250.3.121) 188.299 ms
14 ae-0.a01.snjsca04.us.bb.gin.ntt.net (129.250.3.163) 175.405 ms
ae-1.a01.snjsca04.us.bb.gin.ntt.net (129.250.2.48) 176.148 ms
ae-0.a01.snjsca04.us.bb.gin.ntt.net (129.250.3.163) 189.254 ms
15 ae-0.endurance.snjsca04.us.bb.gin.ntt.net (129.250.195.138) 195.747 ms 196.018 ms 201.185 ms
16 162-144-240-159.unifiedlayer.com (162.144.240.159) 207.900 ms
162-144-240-151.unifiedlayer.com (162.144.240.151) 194.992 ms 206.595 ms
17 162-144-240-127.unifiedlayer.com (162.144.240.127) 198.278 ms
162-144-240-131.unifiedlayer.com (162.144.240.131) 196.392 ms
162-144-240-123.unifiedlayer.com (162.144.240.123) 188.149 ms
18 192.232.219.195 (192.232.219.195) 189.658 ms 188.588 ms 192.262 ms
Angelas-MacBook-Air:~ Angela$

0 Kudos
Reply
  • 5.44K
  • 425
  • 912
Tudor
Superstar
607 Views
Message 2 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

The *** are not a problem. They just mean the server is not accepting ICMP messages, which are used for a trace route. It times out and then goes onto the next hop. A real data gram would not get this timeout. My traceroute takes about the same time, with the same number of hops, as yours.

The gator****** address resolves ok for me and I can get up the web page.

I’ve checked your DNS records and the MX and TXT records for mail look ok.

There is one user on the board who is very good with email problems and he will possible pick up your post.


There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal
  • 11.49K
  • 1.05K
  • 2.46K
griffin
Alessandro Volta
595 Views
Message 3 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

The routing is a bit odd, taking a cheap flight to Amsterdam and then the Greyhound to Houston, probably why you are getting around the 195ms ping time ( I get the same). As said, the stars are just the servers configured to ignore ICMP timeout echo requests.

I am not convinced this is a mail issue as it works on other networks and I can test the Funny Matters E Mail fine.

It would be useful if you can connect a device directly to the Hub by Ethernet cable and put the Hub into Modem Mode, (You may need to reboot the Hub to get a connection). This will give you a different IP address which will test if your IP address is being block by HostGator. (it wouldn't be the first time a Hosting Company has said they are not blocking an IP address when they were, as it is not unusual for IP addresses to get inadvertently caught up in Spam filters.

Remember you will need to use http://192.168.100.1 to put the Hub back into Router Mode.

  • 17.1K
  • 937
  • 6.86K
Superuser
Superuser
589 Views
Message 4 of 27
Flag for a moderator
Helpful Answer

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Hi Guys

First of all I'd like to say thanks to Tudor for bringing me in on this.

I can't produce meaningful traceroutes myself at the moment but my first thought was that it's not a routing issue.

With the Cpanel address reporting not responding to you - I decided to have a look at that first and tried connecting:

pagetest.JPG

As you can see - it's working here - So whatever's going on, it's not a complete block by Virgin Media.

Note:  I'll come to the mail server issue shortly - please bear with me here.

Some of my testing methodology it a little messed up at the moment.  I can't go into full details as to why.  However I can currently work around the issue in order to do some required checks.  So the first thing I did was to do a DNS lookup using Virgin Media's DNS servers.

 

C:\Users\timdu>dig @194.168.4.100 gator3042.hostgator.com

; <<>> DiG 9.10.6-P1 <<>> @194.168.4.100 gator3042.hostgator.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27152
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;gator3042.hostgator.com.       IN      A

;; ANSWER SECTION:
gator3042.hostgator.com. 0      IN      A       62.252.172.241

;; Query time: 22 msec
;; SERVER: 194.168.4.100#53(194.168.4.100)
;; WHEN: Wed Aug 01 03:30:39 GMT Summer Time 2018
;; MSG SIZE  rcvd: 68

Now I recognise that IP address - that's not the right IP address - it's Virgin Media's Websafe platform - So once again Virus Safe is causing issues here.

 

I did a comparison using a different DNS server

 

C:\Users\timdu>dig gator3042.hostgator.com

; <<>> DiG 9.10.6-P1 <<>> gator3042.hostgator.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37267
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;gator3042.hostgator.com.       IN      A

;; ANSWER SECTION:
gator3042.hostgator.com. 28622  IN      A       50.87.144.61

;; Query time: 7 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Wed Aug 01 03:31:12 GMT Summer Time 2018
;; MSG SIZE  rcvd: 68

 

The above result is the right result.  Virgin Media are once again unintentionally blocking the site.  My personal feeling is that based on this and other results - Virgin Media's current Virus Safe offering is a liability and needs reviewing.

@ModTeam - Can you get someone to take a look at this?

@triedandtested - Currently there are three potential fixes for this.  Two you can do now, and one needs Virgin Media's involvement - which is why I've flagged this up to the Moderators - so they can get the Forum Team to take a look.

The two things you can do are either:

  • Switch Virus Safe off on your account.
  • Stop using Virgin Media's DNS servers (which will actually be the same as switching Virus safe off.  Virus safe works by modifying DNS lookups made by Virgin Media's DNS servers in order to divert connections to potentially insecure sites to pass through a proxy on Virgin Media's network)

The proxy that Virgin uses only allows connections on the normal web ports (80 and possibly 443) - and so inadvertently blocks connections on other ports (The cpanel connection connects to port 2083, which is why you get not responding when attempting to connect)

To confirm the result - open up a terminal on your computer and type in:

 

nslookup gator3042.hostgator.com

and post the output.

 

If you wish to turn off Virus Safe - you can do so in the following way.

  1. Log in to my.virginmedia.com using your main account password
  2. Hover over My Apps and then click Web Safe
  3. Turn off Virus Safe and click apply.

Once this is done try connecting to the Cpanel site again.

My personal preference is to switch off Child Safe as well.  However Child safe is not causing the issue so you can leave it switched on.  The reason I choose to switch it off is because I hate any technology that deliberately modifies DNS lookups.  It's breaking how the web was intended to work.

Now the Mail server issue:

While the cpanel issue is down to Virus Safe - the same can't be said of the mail servers - Unless of course I've got the hostnames of your mail servers wrong.

However I decided to concentrate on a single domain first of all

 

C:\Users\timdu>dig @194.168.4.100 mx funnymatters.co.uk

; <<>> DiG 9.10.6-P1 <<>> @194.168.4.100 mx funnymatters.co.uk
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9909
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;funnymatters.co.uk.            IN      MX

;; ANSWER SECTION:
funnymatters.co.uk.     14400   IN      MX      0 mail.funnymatters.co.uk.

;; Query time: 217 msec
;; SERVER: 194.168.4.100#53(194.168.4.100)
;; WHEN: Wed Aug 01 04:27:18 GMT Summer Time 2018
;; MSG SIZE  rcvd: 68

Now as far as I can tell the MX record is ok.  hostgator appear to be using smarthosts where the same IP address manages incoming and outgoing mail, in the case of SMTP - rules will be set up to prevent the mail server being an open relay and the server accepts connections on the following ports

 

POP3
110 no SSL - (Not recommended)
995 SSL/TLS

IMAP

143 no SSL (Not recommended)
993 SSL/TLS

SMTP

25 (Plain and StartTLS) - usually reserved for the mail server to perform it's function as a Mail Exchanger - While you can send over this port, it's not recommended.
465 (SSL/TLS) - While you can send outgoing mail using this port - it's use was actually deprecated so you should use the port below when sending. 
587 (Plain and StartTLS) - The currently accepted port for sending mail. - You should always specify StartTLS as the connection type.

Note:  I've included all the ports for completeness - As indicated you should only connect to your mail server using SSL/TLS or in the case of SMTP StartTLS

Note also that when I do a DNS lookup of mail.funnymatters.co.uk - I get the following result

 

C:\Users\timdu>dig @194.168.4.100 mail.funnymatters.co.uk

; <<>> DiG 9.10.6-P1 <<>> @194.168.4.100 mail.funnymatters.co.uk
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10945
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;mail.funnymatters.co.uk.       IN      A

;; ANSWER SECTION:
mail.funnymatters.co.uk. 14400  IN      CNAME   funnymatters.co.uk.
funnymatters.co.uk.     14383   IN      A       192.232.219.195

THIS IS BAD - I CANNOT STRESS THIS ENOUGH!!

The DNS standard for an MX entry is that it CANNOT POINT TO A CNAME record.  It must point directly to a hostname that resolves via an A record (IPv4) or AAAA record (IPv6)

Either yourself or hostgator need to change mail.funnymatters.co.uk to be an A record pointing at the same address as funnymatters.co.uk

The alternative is to point your MX record to funnymatters.co.uk - HOWEVER it's not recommended to use the bare domain for an MX record.

This is slightly off topic - but important to resolve nonetheless.

I need you to confirm what current mail server settings you are using for IMAP/POP3 (as appropriate) and SMTP in your email programs.

Once I have this information I can advise further.

Tim

 Edit:  Checking your other two domains

C:\Users\timdu>dig mail.brightonfoodtours.com

; <<>> DiG 9.10.6-P1 <<>> mail.brightonfoodtours.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35880
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;mail.brightonfoodtours.com.    IN      A

;; ANSWER SECTION:
mail.brightonfoodtours.com. 14400 IN    A       192.232.219.195

;; Query time: 232 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Wed Aug 01 04:56:21 GMT Summer Time 2018
;; MSG SIZE  rcvd: 71


C:\Users\timdu>dig mail.brightwellcreative.co.uk

; <<>> DiG 9.10.6-P1 <<>> mail.brightwellcreative.co.uk
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24207
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;mail.brightwellcreative.co.uk. IN      A

;; ANSWER SECTION:
mail.brightwellcreative.co.uk. 14400 IN A       192.232.219.195

;; Query time: 257 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Wed Aug 01 04:56:59 GMT Summer Time 2018
;; MSG SIZE  rcvd: 74


C:\Users\timdu>

Shows that the records resolve correctly to A records - so it's just the funnymatters.co.uk domain that needs that part correcting.

Tim

________________________________________


Only use Helpful answer if your problems been solved.

  • 10.87K
  • 406
  • 1.24K
Forum Team (Retired) Nicola_C
Forum Team (Retired)
575 Views
Message 5 of 27
Flag for a moderator
Helpful Answer

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Thanks Tim!

Morning triedandtested

I am sorry we didn't get to this earlier when you called in, apologies as it sounds most frustrating. As Tim kindly found it seems to be routing via our Websafe proxy 62.252.172.241, this is normally because the site has been picked up with suspect content with regard to Virus/Childsafe safe, I have asked the relevant team to check why it is on the list, in the meantime as Tim said a workaround would be to temporarily change your DNSs ones other that ours or to switch Websafe off 

Once we hear back I will update you

Thank you for you patience

Nicola

Virgin Media Forum Team
  • 17.1K
  • 937
  • 6.86K
Superuser
Superuser
572 Views
Message 6 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Just so people are aware - the issue with Virus Safe does not explain ALL the issues that the OP is having.

Which is why I'm looking at the mail server issue separately.

Tim

________________________________________


Only use Helpful answer if your problems been solved.

  • 8
  • 0
  • 4
triedandtested
Tuning in
558 Views
Message 7 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Hello all...

Thanks so much @ravenstar68 @Nicola_C @tudor & @griffin - I can't tell you how appreciative I am of your thoughtful and thorough help!

Re the Cpanel issue:

Thank you ravenstar68 + Nicola_C - I'm not at home at the moment to see if it works yet, but I'll go ahead and temporarily turn off websafe temporarily until I have heard more from the relevant VM team. Please keep me updated on any feedback on that front, Nicola - thanks.

Ravenstar68 - I did as you suggested and typed in nslookup gator3042.hostgator.com into a terminal window, and this is what came back:

nslookup gator3042.hostgator.com
Last login: Tue Jul 31 17:57:16 on ttys000
Angelas-MacBook-Air:~ Angela$ nslookup gator3042.hostgator.com
Server: 192.168.100.1
Address: 192.168.100.1#53

Non-authoritative answer:
Name: gator3042.hostgator.com
Address: 50.87.144.61

Does that result in what you'd expected?

Re the mail server issue:

Ravenstar68 - thank you so much for your thorough investigation re the separate DNS lookup and the MX entry that is incorrectly pointing to a CNAME record! I will contact Hostgator and report this/request they amend this as you have suggested.

In terms of mail settings info, all accounts are IMAP and seem to use either port 993 or port 143. I'm pretty sure that when I originally set them up I would have set them all up to be 993 (as that is what Hostgator recommended) so I'm not sure why some are now using 143... but it's also possible that my memory is playing tricks on me and they've always been like that!

I can't see any SMTP info other than "gator3042.hostgator.com" but perhaps I'm not looking in the right place?

In case it's useful, I also have the primary & secondary nameserver info:

Primary Nameserver
ns6083.hostgator.com

Secondary Nameserver
ns6084.hostgator.com

I hope that helps, but let me know if you need any other info... and thank you again so much for your help - it's SO appreciated!

Angela

0 Kudos
Reply
  • 8
  • 0
  • 4
triedandtested
Tuning in
555 Views
Message 8 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network


@Nicola_C wrote:

Thanks Tim!

Morning triedandtested

I am sorry we didn't get to this earlier when you called in, apologies as it sounds most frustrating. As Tim kindly found it seems to be routing via our Websafe proxy 62.252.172.241, this is normally because the site has been picked up with suspect content with regard to Virus/Childsafe safe, I have asked the relevant team to check why it is on the list, in the meantime as Tim said a workaround would be to temporarily change your DNSs ones other that ours or to switch Websafe off 

Once we hear back I will update you

Thank you for you patience


Hi again Nicola

As suggested, I just tried to turn websafe off temporarily while the relevant VM team look into the issue further, but after switching it to off and clicking 'apply' it just automatically re-loaded the page and showed it as being switched on again. I tried it a few times and it kept doing the same thing... any ideas? 

Thanks!

Angela

 

0 Kudos
Reply
  • 17.1K
  • 937
  • 6.86K
Superuser
Superuser
530 Views
Message 9 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

@triedandtested

Looking at your lookup:

nslookup gator3042.hostgator.com
Last login: Tue Jul 31 17:57:16 on ttys000
Angelas-MacBook-Air:~ Angela$ nslookup gator3042.hostgator.com
Server: 192.168.100.1
Address: 192.168.100.1#53

Non-authoritative answer:
Name: gator3042.hostgator.com
Address: 50.87.144.61

Now based on that I'd assume you weren't on your home connection when you did that test, as if you were using the Superhub 2 in router mode, the DNS server that comes up is 192.168.0.1

That BTW is the correct IP address for that hostname.

 

Looking at hostgator's email setup pages is IMHO an example of how NOT to write support articles.  I found the information in them confusing - And in case you hadn't realised I tend to have a good idea about what I'm talking about.

However I'm basing my information on my DNS lookups AND some common information I've found amongst all the settings which would confirm this.

Assuming your domain is example.com

Then your mail servers should be the following.

POP3
Server: mail.example.com
Port: 995
SSL/TLS: - enabled
Username is your full email address e.g a.n.other@example.com

IMAP
Server: mail.example.com
Port: 993
SSL/TLS: Enabled
Username: your full email address

SMTP:
Server: mail.example.com
Port:587
StartTLS (On Mac select SSL and it will use the correct method based on the port)
Authentication: Yes (Password on Mac)
Username:  Your full email address.

Have a look at this video from Hostgator.

https://www.youtube.com/watch?time_continue=172&v=45Ex9uwTInc

Tim

 

 

________________________________________


Only use Helpful answer if your problems been solved.

0 Kudos
Reply
  • 10.87K
  • 406
  • 1.24K
Forum Team (Retired) Nicola_C
Forum Team (Retired)
501 Views
Message 10 of 27
Flag for a moderator

Re: Unable to send or receive Hostgator server emails with Virgin Media home wifi network

Morning Angela

Thanks for trying, I am sorry you had difficulties, but as you say I can see it is still activated. Please would you have another attempt using a different browser:-

  • Sign in to your My Virgin Media account at virginmedia.com/myvirginmedia
  • Click on My apps
  • Click on Web Safe
  • Click Settings

Normally I would be happy to do it for you however it would not be allowed via the forum in your case as I would need to pass data protection checks directly with the named account holder. Fingers crossed it works for you this time though...

Thank you

 

 

 

Nicola

Virgin Media Forum Team