Menu
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
198 Views
Message 1 of 6
Flag for a moderator

Ports are not forwarding

I have already tried many thing in order to get this working like factory resetting my router but i still can't get these ports (8888 and 3000) open. i am trying to open them to my raspberry pi so there shouldn't be a firewall on my device. I have successfully opened port 22 for ssh and can connect through that port but any other port i try it doesn't want to work.

I have used https://canyouseeme.org/ to check the ports.

My settings:

Dave1111_0-1603997054025.png

 

Tags (3)
0 Kudos
Reply
Highlighted
  • 14.76K
  • 621
  • 1.42K
Alessandro Volta
195 Views
Message 2 of 6
Flag for a moderator

Re: Ports are not forwarding

Maybe ports 8888 and 3000 are UDP so port tester only test TCP.
---------------------------------------------------------------
0 Kudos
Reply
Highlighted
  • 116
  • 11
  • 29
On our wavelength
180 Views
Message 3 of 6
Flag for a moderator
Helpful Answer

Re: Ports are not forwarding

Are you certain that your pi is actively listening on those ports?

netstat -an | grep 3000 

( or 8888 ofc ;))

0 Kudos
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
165 Views
Message 4 of 6
Flag for a moderator

Re: Ports are not forwarding

Thanks for the pointers, for some reason my express api server was listening to a different port that i set but fixed that now.

Also i found that this command worked better for seeing active ports: sudo lsof -i -P -n | grep LISTEN

 

sorry for the late reply as well

0 Kudos
Reply
Highlighted
  • 116
  • 11
  • 29
On our wavelength
160 Views
Message 5 of 6
Flag for a moderator

Re: Ports are not forwarding

netstat -an | grep LISTEN would give you the same 

lsof is for seeing what files are "open" but that will include network ports  🙂

whatever works though 🙂

Highlighted
  • 3
  • 0
  • 0
Joining in
152 Views
Message 6 of 6
Flag for a moderator

Re: Ports are not forwarding

Ok, thanks for the help
0 Kudos
Reply