Menu
Reply
  • 263
  • 2
  • 18
roughbeast
Up to speed
858 Views
Message 1 of 13
Flag for a moderator

Latency and disconnects Battlefield 4 Windows 10.

I have been using Battlefield 4 on my Gaming PC for some months now. It was fine for a long time. After a system fault developed ,where I had to clean reinstall Windows, I have suffered lag and frequent disconnects from game servers. I have tried configuring my router for gaming and have trialed WTFast for a few weeks and have updated all gaming and system software.  No improvement!  Latency to servers is always pretty good anyway, never more than 40, so I guess my connection is OK. Also another user in the house has no problem with Battlefield 4 on their gaming machine (Windows 10) . 

 

So, the problem must be my PC. Are there any specific Windows 10 configuration tricks I might be missing? 

Location: Coventry Cab CV826
Services: 500Mb / 35Mb, TV V6 box X2, Phone XL Talk unlimited and mobile x4 Routers = SHub 3 in modem only mode with Asus RT-AC88U
0 Kudos
Reply
Highlighted
  • 9.07K
  • 248
  • 545
Forum Team (Retired) Nat_J
Forum Team (Retired)
816 Views
Message 2 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

Sorry to hear about this roughbeast, 

 

I've located your details and your connection appears to be clear of any active faults relating to this. 

 

Hopefully, someone from the Community will be able to step in and offer some further support regarding your equipment. 

 

Nat_J


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 403
  • 18
  • 119
Luke_113
Fibre optic
811 Views
Message 3 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

Have you installed Windows 10 creators update 1803? This was known to cause a whole bunch of issues, which I thought had mostly been fixed since (so just ensure you have all updates done etc...)

Have you checked the 'Game Mode' in the Simpletons Control Panel? (The cog off of the start menu) since 1803 your system will or will not support gaming mode, if it does, try turning off game mode via the registry, you can do a quick google that will explain how to change this, for me this made an improvement in some games and worse in others, so your mileage may vary.

I play HoTS (Blizzard MOBA) alot and this suffers from archaic netcode from StarCraft2 and so follows every move and click every player and NPC makes and syncs them, with the combination of Virgin's not great core, my local area over utilisation (about 95%+ at this time), and the woeful Puma6 chipset (which to be fair is drastically improved with the new firmwares being rolled out)

Next because HoTS and OBS (streaming software) do NOT play nice at all, again because HoTS is based on old code, combined with the packet loss and stuttering caused by the modem means my game will do ALL sorts of weird things, from reading through HoTS forums I found and have had mixed results with a free program called Program Lasso think of it more as an advanced task manager, this allows you to permanently set cpu core affinty for games and makes another noticeable difference, I have these issues and still stream mostly without issue (other than my stream being kicked offline as the area is over utilised), PM if you want my twitch channel and you'll be able to see streams from the last few weeks, and also if of interest see the spec of my rigs - as I couldn't pin point the issue of stuttering etc... so moved to a 2 PC streaming setup.

Hope some of this is of use
0 Kudos
Reply
  • 263
  • 2
  • 18
roughbeast
Up to speed
805 Views
Message 4 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

Thanks for eliminating that issue. Annoying thing, another, less powerful,  gaming machine in my household has none of these problems. 

Location: Coventry Cab CV826
Services: 500Mb / 35Mb, TV V6 box X2, Phone XL Talk unlimited and mobile x4 Routers = SHub 3 in modem only mode with Asus RT-AC88U
0 Kudos
Reply
  • 403
  • 18
  • 119
Luke_113
Fibre optic
802 Views
Message 5 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

What components have you got in your system, for example for my Astro A40's to get the best sound I have to use a Dolby Digital Live audio card, which means I have to use a slot in PCIE soundcard, I use a very old Soundblaster Recon3D PCIE and I haven't elimintated this as part of the problem as I get audio pops and clicks when I have issues, but not yet pulled the card to see if thats part of the problem, but I'm quite lucky in that the 1803 update hasn't borked this for me when I've read all sorts of random devices that worked fine pre 1803 just don't now.
0 Kudos
Reply
  • 263
  • 2
  • 18
roughbeast
Up to speed
797 Views
Message 6 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

 What I will do is explore some of your suggestions and then report back.

 

I haven't installed Windows 10 'creators' update, although I obviously have the regular Windows 10  1083 update.

 

Thanks

Location: Coventry Cab CV826
Services: 500Mb / 35Mb, TV V6 box X2, Phone XL Talk unlimited and mobile x4 Routers = SHub 3 in modem only mode with Asus RT-AC88U
0 Kudos
Reply
  • 403
  • 18
  • 119
Luke_113
Fibre optic
788 Views
Message 7 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

That is the creators update, its the terminology microsoft have moved to I believe doing them 2-3 times a year, as opposed to the service packs of old.

Please do and report back, happy to help if I can
0 Kudos
Reply
  • 263
  • 2
  • 18
roughbeast
Up to speed
785 Views
Message 8 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

How come I am on creator's update without asking to be?  Can I go back to the old set up?

 

Location: Coventry Cab CV826
Services: 500Mb / 35Mb, TV V6 box X2, Phone XL Talk unlimited and mobile x4 Routers = SHub 3 in modem only mode with Asus RT-AC88U
0 Kudos
Reply
  • 263
  • 2
  • 18
roughbeast
Up to speed
782 Views
Message 9 of 13
Flag for a moderator

Re: Latency and disconnects Battlefield 4 Windows 10.

I built the system myself over Christmas. All ran well, with no disconnects,  until I had to reinstall Windows 10 from scratch in May.

 

Processor - i5 7400 CPU 3GHz

Video - GeForce GTX 1060

Motherboard - Z270 - Gaming K3

RAM - 16Gb  suitable speed for gaming.

Location: Coventry Cab CV826
Services: 500Mb / 35Mb, TV V6 box X2, Phone XL Talk unlimited and mobile x4 Routers = SHub 3 in modem only mode with Asus RT-AC88U
0 Kudos
Reply
  • 403
  • 18
  • 119
Luke_113
Fibre optic
772 Views
Message 10 of 13
Flag for a moderator
Helpful Answer

Re: Latency and disconnects Battlefield 4 Windows 10.

Almost certainly by the sounds of it, the kit is all new enough that I don't believe it would suffer any issues.

In terms of the BIOS firmware on the motherboard, is this up to date? Did you have any kind of overclock running prior to the last firmware update, was helping the streamer Sacriel with his pc issues a few months back and it turned out the old overclock was still applied on the newer firmware and wasn't playing nice. I do not you have the non K however which are harder to overclock.

You CAN opt out of the creators update, but I honestly wouldn't it fixes and improves more than it breaks IMO.

Power Options within windows, have you set this to high performance? as by default windows will set itself to balanced which will down clock the processor when not under load - this can be disabled in BIOS via swtiching off things like C States, however just putting it in High Performance mode is the best option this will keep the CPU at its base speed as the lowest speed and then only turbo up to whatever the 7400 clocks to 3.5Ghz at a guess? One of my servers was really sluggish when I was using it and also when using a program remotely on mobile and realised that was what I hadn't done, if you don't know how to locate this, click start type 'Con' and it should be enough to bring up Control Panel and then look for 'Power Options' or use the search box in the corner and if its not immediately there you should be able to click 'Show Additional Plans' and you should see it.

Hope this helps
0 Kudos
Reply