Showing results for 
Search instead for 
Did you mean: 

Cannot Port Forward on Hitron Chita router

Tuning in


We have just signed up for a Virgin Business Fibre broadband service. They have sent us a Hitron Chita router which is basically working (i.e. we have internet), but we are unable to create Port Forwarding rules

When I go to the Port Forward section on the admin screen, I can 'add' a rule, and enter the details, but when I 'save' the rule, it takes me back to the port forwarding screen saying 'changes have been saved', but no rule is visible.

If we reboot the router, then sometimes a rule will be visible but the details are wrong (everything is set to zero) and the rule is set to 'Not' enabled. If I try to edit the rule, it appears to work but nothing changes. 

I have had several phone calls with Virgin Tech and Customer support but they don't seem able to help.  

We originally signed up with a static IP address, but someone at Virgin told me yesterday that Port Forwarding won't work with static IP. So we changed our account to Dynamic IP, and were told to wait 24 hours before trying again. We have waited and it makes no difference. It doesn't feel like the choice of dynamic/static IP would make any difference, as it feels more like a problem with the router itself - i.e. we are unable to save changes on the Port Forwarding page.

Has anyone seen similar issues before, or knows the truth about whether Port Forwarding will work with the way Virgin Fibre is set up?




Accepted Solutions

Not applicable

This is a residential forum only I'm afraid. You will need to contact the business team

See where this Helpful Answer was posted


Not applicable

This is a residential forum only I'm afraid. You will need to contact the business team


There doesn't seem to be a support forum for Business Broadband, and the support team on the phone are very limited in what they can do. If they test the line to the router, and can see that it is up and running, then they will do nothing else. If I mention Port Forwarding, they say they don't support router configuration and there is nothing they can do. I have phoned several times this week, always get a different person, and each one has a different excuse or reason for the problem, with an additional delay before I can escalate. If does not seem to be possible to speak to a technical person with genuine knowledge about what may be the issue.  My impression so far is one of really poor customer service. I would have thought that Business Support would have been better, or at least that the routers supplied would have been reliable.



Alessandro Volta
Get a Zyxel security firewall and put the hub in modem mode

Joining in

I had EXACTLY the same issue and reported this to Virgin.
They said they are aware this is an ongoing issue, but can't give a fix time or tell me how long it's been going on.

However, I fixed it!
I noticed that port forwarding does work for devices that get a DHCP address, so (assuming your device has a static IP) you need to do the following:
-Change the DHCP range to include the IP address you want to forward to ( -
-Create a DHCP reservation for the devices MAC address and static IP address (so you don't get an IP clash when the router gives out the same IP)
-Create the port forwarding rule successfully.

Hope this helps! 🙂

This is for the CGNV4. There's nothing on the newer Chita even though this has been out for sometime.

I can understand that business or residential support can't really help with customers' router but at least they can provide some documentation for their own products.


Do you mean the 'fix' above is for the CGNV4? Anyway, I have asked our local network support guy to take a look at the suggestion and see if it works for us. Really not at all impressed with Virgin at the moment. We might have to go down the route of purchasing a decent router as suggested above, although it's still not clear whether the way the Virgin network is set up blocks some of our applications anyway.

Thanks for everyone's help with this - good to know we are not alone 🙂


This saved me from going nuts!  Thanks.  Just a pity my DHCP server and my router are now defunct.  Time for a router upgrade that supports GRE so I can use my own equipment.

VM will not tell you the GRE IP end point.

Spot on mate, just been trying all morning, read post bang sorted. Thx