Showing results for 
Search instead for 
Did you mean: 

Hub 5 in Modem mode with Tenda MX21 Pro

Tuning in

Appreciate there have been previous posts on this but in case there has been a solution, here is my issue.

Previously, I had the Hub 3 and TP-Link Decco and all was ok but Id had a few years and wanted to upgrade. After lots of research, I ended up with the Tenda MX21 Pro (3 pack) with wifi 6e. It was bit more of issue to set up and get going than the Decco and found it had to be done in a very specific way to get the Tenda to pick up and address and connect but eventually I got it going.

I recently upgraded to the the 1Gig service which meant an upgrade to the Hub 5. Arrived today and when I finished working, I set about trying to set it up. Initially boot up and connected, tested the speed and getting full gig speed. So changed to modem mode so try connect to the Tenda and that's where it all stopped! 

Try as I might, they two would not communicate in modem mode. (connected to port 4) 

When I reset the hub and it goes into router mode, it will talk to the Tenda, but not in Modem mode. With the Hub 5 in modem mode, I connected the deco to the Hub and then to the Tenda and that worked but direct (not having any of it)

Called Tech and of course was no help whatsoever, initially telling me because I has a green light it wasn't on line and I had to direct her to their own website and explain that when it is in modem mode, it's not white, it's green! She then tried to fob me off saying because I've upgraded my speed, its too fast for the Tenda!! I gave up at that point!

So yes I could leave it in router mode but I'd prefer not to and would like it to work as it should in modem mode. 

So is there an answer as I feel like I've exhausted many things but open to any suggestions if anyone might have.  (I have done the specific order of connection as other posts)

Thanks in advance


Community elder

Looking at the spec of the Tenda MX21 Pro it only has 1Gbps ethernet ports so no reason to use the 2.5Gbps ethernet port on the HUB 5 (Limited to around 900-940Mbps).

Ensure you only have one ethernet connection to the HUB 5 (One of the 1Gbps ethernet ports to the main Tenda node WAN port), then reboot both the HUB and the Tenda.


The 2.5Gb/s port has compatibility issues since the recent firmware updates.
Read the link below ... note the comments on EEE Energy Efficient Ethernet.

I have tried the other ports out on the hub 5 into the Tenda but same result (flashing red).

Hub Firmware is LG-RDK_7.6.15-2306.5 however at present, (in router) mode, I am connected to and using the the 2.5gb port on the Hub 5 into the mesh and that works, just not in Modem mode. 



Given we know there are possible issues with the 2.5Gb/s port and that there is no gain to be had for the Tenda it might be best to use a 1Gb/s port to avoid risk of sudden service failure due to an over night firmware update.

Take a look at the thread below, find the entry from Tudor ... the steps for switching to modem mode are critical both for the Hub and for your Tenda Router.


Sorry, I know my post was a bit long! (I rambled) but did all the steps suggested in that very thread to no avail including using the 1GB ports..  Only seems to connect to the Tenda on router mode

Alessandro Volta

Get a router a mesh causes problems with the hub knowing what MAC you want to use.



Not overly helpful that! 


@marko8207 wrote:

Not overly helpful that! 


Just ignore them. They can barely string a comprehensible sentence together at the best of times!

Community elder

So, one thing you could try is to plug a wired device (Laptop or PC/MAC) directly into the HUB (Ensure nothing else wired is connected), reboot the HUB, and that device should get an IP address (Not the standard mind you) and internet access.

You could then make a note of the MAC address of the device's ethernet adapter, then use the 'Clone MAC' advanced settings in the Tenda to 'pretend' to be the wired device (You can type in the MAC address, OR connect the wired device to the Tenda to copy the address directly).

Swap over from the wired device to the Tenda, then reboot both the HUB and Tenda again.