Speed
We like it fast
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! Our Router doesn’t deliver the Wi-Fi through the house

We live in an old sandstone house. We have some thick internal walls. Some rooms don’t receive much if any Wi-Fi and we have issues streaming tv. we have used the connect app but anytime we try and get through to customer services they fob us off and...

iainpol by Joining in
  • 682 Views
  • 9 replies
  • 0 kudos

Gig1 upload speed half what it should be

 this is from my hub i pay for Gig1 broadband and was told that i would get 104mbs upload the best i have got since i signed up is 53 mbs i live in area30 when will the upload speed be what i am getting charged for 

Untitled.jpg
adeysmrs by Tuning in
  • 1205 Views
  • 13 replies
  • 2 kudos

Resolved! Engineer updates?

I've had a few connection issues for the last 3 days, and I'm not alone as a local community Facebook group has also had multiple comments re 'Virgin Media not working'.When I click on 'Check service status', it replies with:We can’t see any issues a...

vm1 by On our wavelength
  • 752 Views
  • 6 replies
  • 0 kudos

Hub 4 no internet

I have been having issues with my hub 4 for a few weeks. When powered on its fine for a few hours - good speeds up and down. But then the speed starts to fade until there is virtually nothing (0.1 to 10 Mbps on a gig1 plan). It's looks like a faulty ...

Resolved! Slow speeds 1Gig

Hi EveryoneLooking for some help. I've been trying to set up deco px50 and discovered whilst in modem mode with my hub 4 that I was getting below 50Mbps.Resetting the hub was problematic and it took 3 attempts to get back to router mode. Speed tests ...

CaptainW by On our wavelength
  • 855 Views
  • 8 replies
  • 0 kudos

Upload speed is near zero

Hi there,Last few days I had an issue with my upload speed. But all is fine with download one (it's 385Mbps). Hance, sometime wifi is not usable at all. Could you help and check your broadband's upload speed in my area? Here is my hub speed test in m...

Screenshot_20230720-235931.jpg
VladD by Joining in
  • 218 Views
  • 2 replies
  • 0 kudos

Declining Speeds

I have been experiencing declining speeds from my Hub 4 router in recent weeks. When switched on in the morning I get good speeds (both up and down - Gig 1 plan). However, as the day progresses the speeds drop off dramatically (down to as low as 5Mbp...

Terrible upload speed for the last month

Since some work in my area, my upload speeds have dropped to almost nothing. Some days it'll go as high as 10 mbps, but most of the time it hangs around 2-3 mbps. Download has been completely fine.I'm on M350, so I should be getting ~36 mbps up.  Her...

msedge_Pfdv1VFjVe.png msedge_U2wL6rdW7y.png msedge_ahut4WBArz.png

New 1gb install

Recently just upgraded from the 500mbps  package to 1gig new hub 5.PC down speed 750mbps well short of max.upload speed reaches max ok.Laptop wi-fi mid 500mbps down up 104 mbps.Have checked all settings and connections and using quality ethernet cabl...

barrym by On our wavelength
  • 1189 Views
  • 16 replies
  • 0 kudos