QuickStart, set up and connections
Installing and configuring your kit
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Hub 5 - pages won't load

I have the hub 5 and recently I’m having issues loading pages on all devices. WiFi showing full strength but when watching videos-social media they don’t load or have constant buffering.

Nanrek by Joining in
  • 378 Views
  • 4 replies
  • 0 kudos

Hub 4 return - no tracking details

Hi,As part of the black friday offer I upgraded my solo broadband and was sent a hub5 as part of the upgrade.  I managed to install and activate without issue and today I packaged up the old device (hub4) in the box supplied, attached the returrns la...

Nat_merc by Joining in
  • 532 Views
  • 5 replies
  • 0 kudos

Engineering work

What time are engineers allowed to start work outside somebody's property. Had a group of men here twice around 5.30am lifting flags and banging. The worst is the shouting all over the street from the men doing the work. Surely there is such a thing ...

Kush1971 by Joining in
  • 178 Views
  • 1 replies
  • 0 kudos

WiFi fixed.

Following on from my quick start Hub 5  not connecting. The engineer came and fixed it. He said there was a part missing from the box under my window.  Simple fix. All good now.Mark

Markab17 by Tuning in
  • 162 Views
  • 1 replies
  • 0 kudos

Resolved! Reroute external cables

Hi, I've also seen the previous posts re this subject and am hoping someone from the Virgin team can contact me. I have been unsuccesful so far, having used chat where I was promised an email, but this has not arrived.We are having work done on the o...

maryd1 by Joining in
  • 416 Views
  • 3 replies
  • 0 kudos