Showing results for 
Search instead for 
Did you mean: 

Reset password not working

Joining in

I've forgotten my password for my Virgin Media account and every time I try and reset the password it tells me that it is invalid no matter what password I choose (within the limits provided). I've seen on the forum that loads of people have had the same issue over the years but the result doesn't seen to be solved on the forum. Can someone please help?

Literally everything you need to do on the virgin media website requires you to sign in, the live chat section just tells you there is one rather than takes you to a live chat, and the telephone has no relevant options (while clearly trying to avoid anyone speaking to a human).


Forum Team
Forum Team

Hi GWill71583, 

A warm welcome and thanks for posting on our community forums. We do apologise that you are having trouble trying to reset your password to gain access to your online account. 

Can we ask if you have ever been able to access your online account? 

We would ask you to try the basics first, trying a different web browser and device, clearing all cookies caches and history. Also trying to reset via our Virgin Media app. 

We are aware that some people are having an issue with this and there are a few things I need to check with you.

Can you please ensure you are following ALL of the below criteria when choosing a password?

•  Between 8-10 characters.

•  Must start with a letter.

•  Contain at least one number.

•  No special characters.
If you are 100% sure that the above requirements are all being met, can we ask you to try some different password variations? This is because we've had reports of customers being able to proceed when doing this and it's mainly because some choices are too guessable to be allowed.

If this does not work, come back to us. We will then be able to raise this with our IT teams.

Kind regard Jodi. 




Hi Jodi,

I have been able to login in the past yes. Although I have not logged in for about a year, hence me forgetting my password.

As with many people who I have read about having the same issue before me, I have tried everything you have said. Different browsers, clear cookies etc. I have also tried a million different combinations of passwords within the criteria. Considering the amount of threads this issue comes up on (and seems to have as far back as 2019), I’m quite flabbergasted that the same advice is being provided (which isn’t really advice - it’s the equivalent of asking us to switch it off and on and checking if we can follow instructions) when it’s clearly a problem with the Virgin Media system.

Thanks for coming back to the thread. I will PM you now to get this reset and assist further


Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

Joining in

I have the same issue as GWill71583. This morning I changed the email address in my Virginmedia account. The Virginmedia website was running very slowly at the time. I got the email asking me to verify the email address, but no other confirmation that the email address verification had worked. A little later I tried to log in to my Virginmedia account using my new email address, but it didn't like the password that I had entered. So I requested a password reset. I got as far as the 'Choose a new password' section, but as I enter a new password (using just numbers and letters, starting with a letter) I get as far as the 7th character, then when I put in the 8th character, next to the word 'Strength" appears the word "invalid". I have tried using several different letters / numbers, to no avail. Please help.


Hi @MandyGrimshaw thanks for your post here in the Community, although we're sorry to hear of the concerns that you've raised here.

Please allow me to send you a PM so I can look into things further for you.

Kindly expect the PM from me to arrive shortly and respond directly when you can!
Many thanks


Joining in

Hi, I’m having exactly the same issues. So many attempts at new password combinations and using private browser window etc and still I get the error message that the new password is invalid and I should try some other password combination. I also can’t believe this is a known issue for so long and it’s still not fixed ! 
Can someone please tell me how to reset the password as I have no access to my account and desperately need in. 

Hi @Gyyw6 thanks for posting and welcome back to our community.

Sorry to hear you're unable to access your online account and for any inconvenience this may be causing.  I would like to take a look on your behalf. I am going to send you a private message. Please do keep an eye on your inbox in the top right of your screen.



Joining in

Hi, I am not being able to reset my password either. It keeps saying "requirements not met" no matter what password combination I try. Please assist. Thanks!

Hi Anusua,

Thanks for posting and welcome to our community 🙂

Sorry to see you've been unable to update your password, I've popped you over a private message so I can take a few more details from you.