Showing results for 
Search instead for 
Did you mean: 

Page hangs on logging in cant access account

Just joined

When I log in to my account it just stays saying logging in, but never actually gets to my account page.  I can log in ok in the app but need some more functionality using the online account.


Forum Team
Forum Team

Hey @neeliocomp,

Welcome to the community and thanks for taking the time to post your issue on the forums.
I’m sorry to hear of the issues that you’re having with your account. Please can you clear your browsers cache and try to load your account again via the website.



i have the same issue. I have cleared the cache but this makes no difference. I have tried this on Windows PC, iPhone, and iPad. I have used a browser and the iPhone app - all to no effect. 

Hello Ikorzilius


Sorry to hear you're also experiencing issues logging into your online account, we appreciate you raising this via the forums and welcome to the community.


When you try to access it via the Windows PC, are you trying here? What browser are you using? Do you have an alternate browser to try? Can you also try alternate browsers via the iPhone and iPad?



Joining in

This is a common issue, I cannot log on either and if you scroll few this forum you will see quite a few other with the same issue. I have not seen it resolved yet.

It will not make a difference which browser or which device, it just doesn't work.

Hi @Soundy thanks for posting and welcome to our community.

Sorry to hear you're unable to access your online account. And for any inconvenience this may be causing you.  Are your receiving any error messages?  Have you ensured all cookies are enabled?



Joining in

all cookies enabled, no error messages, just hangs.


It’s a virgin backend issue, I’m pretty sure. Maybe i could gave my account deleted and try re registering.

Forum Team (Retired)
Forum Team (Retired)

I will send you over a private message so I can confirm some details with you and look into this 🙂 




Joining in

I have the same problem, logging into the page just hangs.

I have tried clearing the cache and cookies in Chrome and also tried logging in using firefox where I have never logged into virgin media before - same thing happens, the login page just hangs, there is no error message and chrome is constantly using CPU time, so chrome is running.

If there is a solution to this problem, please could the solution be posted on this forum so that other people do not have to keep posting requests for the solution. Thanks.

Thanks for your post on our Community Forums @robinpike, and a very warm welcome to you!

Sorry to hear of the link seemingly not working.

Does this happen on any alternative devices at all?

I've attempted to open the link on my laptop without issue - using Chrome and a Virgin Media Wi-Fi connection.

Can you please confirm how long this has been effecting you?