Menu
Reply
  • 338
  • 9
  • 19
PhilHornby
Fibre optic
1,596 Views
Message 1 of 45
Flag for a moderator

HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

As a result of my 'Speedboost', I've just upgraded from a Superhub 1 in modem mode, coupled with a Draytek Vigor 2830n to a Hub 3, also in modem mode, with a new Draytek Vigor2860n. I upgraded the Draytek first and saw a modest increase in Download speed - then bit the bullet and migrated to the Hub 3. I double-checked I wasn't on an Arris CMTS first!

According to Speedtest.net, everything is wonderful:-

Before: 

After:

However, the equivalent results from Thinkbroadband's speedtester aren't so straightforward.

Before:-

 My Broadband Speed Test

After:-

My Broadband Speed Test

This is accompanied by a warning: "Your HTTPx6 speed is vastly different to the tbbx1 result. This suggests an RWIN, congestion or other problem".

These results are repeatable at will. Speedtest.net says "it's great", thinkbroadband.com says "it's not".

Looking at Thinkbroadband's Broadband Quality Monitor before and after the HUB 3 installation is revealing:-

Before:-  (This is representative of a 'normal' day. I believe the spike's are caused by 'Samknows' tests)

 My Broadband Ping - Valhalla

After:- (The Hub 3 was installed at 1pm; the glitch @ 4am, was me!)

My Broadband Ping - Valhalla

As I understand it, the 'Samknows' data is confidential, so I've not reproduced it here. What it shows in a nutshell, is the Download speed dropping, the Upload speed rising and the UDP latency rising significantly.

I tried a variety of other Broadband speed test sites, one after another:-

For a laugh, here are the results from something I knocked together myself. It has one advantage in that I know precisely what it is doing, and how it measures things:- 

Retrieving: http://speedtest-download.btwholesale.com/PT/random4000x4000.jpg

Data size=                      62,914,858 bytes

Elapsed Time=                   25.234 Secs

Raw bps =                       19,946,059 bps (19.02 Mbps)
bps (latency adjusted) =        19,957,923 bps (19.03 Mbps)
bps (IP overhead adjusted) =    20,706,346 bps (19.75 Mbps)
bps ("ISP" Mbps) =              20,706,346 bps (20.71 Mbps)

I can run half a dozen of these in parallel, and they all run at the same speed.

I'm not actually that bothered about the download speed (but annoyed I've spent a fortune on a new Draytek to handle it). The latency on the other hand looks like a fault to me. I seem to recall the Superhub 2 doing something similar during its trial. I don't know if that ever got fixed - I tossed mine into the junk pile and went back to the SH/1 Smiley Frustrated

 

0 Kudos
Reply
  • 338
  • 9
  • 19
PhilHornby
Fibre optic
1,550 Views
Message 2 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

I somehow managed to post a link to the live TBB BQM graph, instead of the one from the day of the changeover to the Hub3.

This is the proper one:-

My Broadband Ping - Valhalla

From the lack of response, should I take it that no one else has experienced (or noticed Smiley Wink) this issue, when swapping to the Hub3?

(The issue being: greatly reduced download speeds and increased latency - as measured by all speed testers except SpeedTest.net. This is despite the deployment of the Hub 3 activating my supposed Speed boost from 100/6 to 150/10.)

My 'real world' experience of this 'upgrade' is in line with that measured by the Samknows box: slower DNS lookups, longer Web site load times Smiley Frustrated

  • 9.88K
  • 323
  • 854
legacy1
Hero
1,542 Views
Message 3 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

Well this will be forever prove about SH1 to hub 3 of those that denied the claims (you know who you are). True there are VM network issues from time to time that have nothing to do with super hub /hub problems but you can't hide the truth.

Now of course the hub 3 have more channels and likely we will never see a hub 3 on the same 8 channels and setup for just 8 channels that any of the super hubs are on so there is no way we can prove or disprove thats a problem...I'm sure VM can test likely have...but we will never see the report of that out come.

Now VM can admit the problem is only down to the hub 3 having more channels because of the above but the question now is it the problem at the VM gateway end or the hub 3?

what adds to the confusion more is the speed tests for single thread which we know happens on the SH2 but I don't think I've seen a report about it happening on a SH1...so that could be interesting...or is it that a area needs to be setup for the hub 3 at the gateway in such a way that the problem starts to happen and then happens to all...

and yet we will never know...

  • 17
  • 0
  • 3
davidmsims
Tuning in
1,506 Views
Message 4 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

Just want to confirm that I saw EXACTLY the same latency issue with Hub 3 - I have reverted to a Superhub 2 AC

 

 

  • 338
  • 9
  • 19
PhilHornby
Fibre optic
1,496 Views
Message 5 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

I came across another thread - describing similar symptoms, but presumably with a different cause:-

Very poor HTTP download speed

It took a while to read through Smiley Sad

0 Kudos
Reply
  • 17
  • 0
  • 3
davidmsims
Tuning in
1,481 Views
Message 6 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

Here is the pic of me going from a Hub 3 to a Superhub 2AC

 

2ac.png

  • 170
  • 2
  • 54
boltedenergy
Superfast
1,433 Views
Message 7 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

strangely despite the dodgy latency, web pages appear to load much quicker on the SH3 Smiley Tongue

--I'm just another virgin user like you. Please mark my answer as helpful, if it helped Smiley Happy
0 Kudos
Reply
  • 62
  • 1
  • 11
MagicMavis
Dialled in
1,422 Views
Message 8 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

The SH3 is terrible. There is no getting away from that. It is as bad as the SH1 was when in Router mode, just for different reasons. The SH3 should never be considered an upgrade.

Phone VM and make a LOT of noise until they send you a SH2ac. They're the best of a not-ideal bunch.

Actually, phone and tie up an agent for a good hour or so, and fill their Tw@ter feed asking them to provide a modem instead of another woefully inadequate SH. The more people do that the more likely they are to go back to the option of a decent modem instead of a **bleep** router.

 

[MOD EDIT: Inappropriate language removed, please review the Forum Guidelines]

  • 338
  • 9
  • 19
PhilHornby
Fibre optic
1,388 Views
Message 9 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.


boltedenergy wrote:

strangely despite the dodgy latency, web pages appear to load much quicker on the SH3


However, that is at odds with the measurements taken by the 'Samknows' box. It measures Website load times as being 50% worse than before, UDP latency as being 50% worse; even multi-threaded downloads are worse and deteriorating day-by-day. The only thing it measures as better, is Upload speed (Remember, the only reason I have a Hub 3, is as part of a 100/6 -> 150/10 'speedboost'.)

 

0 Kudos
Reply
  • 170
  • 2
  • 54
boltedenergy
Superfast
1,376 Views
Message 10 of 45
Flag for a moderator

Re: HUB 3 'upgrade' has drastically increased latency - and gives odd speed test results.

I didn't really test it properly to be honest, it just felt a little more responsive... so no disagreement there with your stats. Smiley Happy

--I'm just another virgin user like you. Please mark my answer as helpful, if it helped Smiley Happy
0 Kudos
Reply