Showing results for 
Search instead for 
Did you mean: 

TV Control app won’t let me sign in

Joining in


I have been trying for days to get logged into the tv control app. The error I get is

“Your email or password was incorrect. Please try again or go back to change your email” 

I am using the correct my virgin media details as I have always used, I am currently logged in on the TV to go app, my virgin media app and the virgin media connect app. So why can’t I get the TV control app to work?

my husband is getting the same error when he tried and we have tried on our tablet device. I have uninstalled the app. 

is there anything else I can do?


Forum Team
Forum Team

Hi Lee-AnnL, thanks for the message and welcome back to the forums. 

I am sorry to hear that you are having issues with the app, this will use the same password as the online account. 

Can you clear all the cache and cookies and change the password to see if it allows access?

Please let us know how it goes?

Kind regards, Chris. 

Dialled in

I am having an identical problem after installing the app on a new phone

Forum Team (Retired)
Forum Team (Retired)

Hi, snowglowjoe.
Thanks for reaching out on our help forums and this thread, sorry to hear you're having issues with accessing your TV Control App installed on a new device.

As advised on our above post replies the password used for this should be same with your MyVM account password, you may find all our up-to-date info regarding TV Go App on our link here for our reference.

Could you see if clearing your device/browser cache and cookies helps with resolving the access error on the App?
Also, you may see if a password reset helps with gaining access back to the account and T Go App - let us know if this helps and if you need further assistance from us here.

Glad to help out. 🙂

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Interesting thread.

I've just installed on a new device & TV Control will not log me on.I get a message saying "Sign In Error"  & Login Error" with the options to "Return to Sign In " or "Exit".

I have tried reinstalling the APP with no change. I then changed my email address followed by a new password. None of these steps has given a different result.

All other VM apps have singed in OK with the new details.

My assumption is an APP error which needs fixing. 


Joining in

I can’t install Virgin control app on my new iPad. My error message says

server error

what would you like to do?

Try again ( with a tick in front that I can’t delete)

Then. OK

press ok only to return to the same sign in error!!



Hey @davidlapham, thanks for reaching out to us and a warm welcome to the Virgin Media Community forums. 👋🏼

I'm sorry to hear about the issues with the TV control.
May I ask if you've been able to try another device?
Is your device up to date with the firmware and is the app the most recent one?
What device are you using?

Let us know.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

@Ilyas_Y Thank you for your reply............

My original device was an Xperia5 111 (worked perfectly)

My new device is an Xperia 10 V (cannot complete login)

I have gone back to my original device & that now will not complete login.

Both devices are running Android 13 & all security updated installed.

I have cleared Cache & Storage (no change)

I have uninstalled / reinstalled (no change)

I have changed my password, as suggested (no change) All other VM APPs login perfectly.

I have changed my login email address, as suggested (no change) All other VM APPs login perfectly.

I have read elsewhere on this forum Engineers have been notified & are looking into a fault with the APP?

I look forward to a functioning APP in the near future.


Hi @davidlapham, thank you for your response.

In order to look into this for you further, we'll send you a private message on here. Look out for the envelope in the top right-hand corner.

If you're on a portable device with a smaller screen, click on the icon in the top right-hand corner and select "messages" from the additional menu options.


Joining in

I've got the same problem. I have installed the TV Control app on a new Samsung A34 phone but I keep getting 'Login Error'. Tried re-installing and resetting my password but still will not log in.

It still works ok on my old Samsung S6.