Showing results for 
Search instead for 
Did you mean: 

Can't Manage Virgin Media Stream

Tuning in

I am seemingly unable to access the Virgin Media Web page where you manage Stream (below):

I have attempted to access it a number of times over two weeks but I get the loading sign (spinning Virgin Media sign) but it never loads. 

I can access other parts of the websites (I. E. My bill and person info but not this section. 

See photo of the page it gets stuck on below:


For reference, I have attempted to access the website on my mobile, laptop, tablet and a separate laptop and get the same problem every time.

I really need a resolution to this as I don't have time to spend 30-45 mins waiting on a phone to check on subscriptions and/or cancel them.


Tuning in

I think it's the same for everyone, certainly is for me and quite a few others that have posted, but I've yet to see a response from virgin even to acknowledge that the problem exists.

Forum Team
Forum Team

Hi @RJHeald 

Welcome back to the community forums  

Sorry to hear you're also having issues with your set top box. 

Do you get the same error on another device or browser at all when trying to access the stream management page?

Here to help 🙂
Virgin Media Forums Agent

Tuning in

Hi @Carley_S

Same error on all devices: PC, Laptop and Phone using Edge or Chrome browsers. Here's a screenshot of the page on my Pixel 7A using Chrome


My stream box works fine, no issues with that, just can't access the management page same as many others.

Carley_S, RHHeald is experiencing exactly  the same issues as myself and many others been reporting – here and here are two example threads, still unresolved. It's got nothing to do with the puck itself, it's when we try to access that link online to manage our stream services. Doesn't matter what browser or platform.

Dialled in

Im experiencing exactly the same issue it has been like this for weeks and all we see are inane responses from Forum team members asking the same questions which they already have the answers to

Virgin check your end and you will see!

Dialled in

I'd suggest people raise complaints here over this and lack of acknowledgement or support on it 

That's a very good idea, Mattc86. I've cut'n'pasted my complaint below, in case anyone else would like to use the same wording. I listed it as 'an issue with VM apps' as there seemed to be no category more appropriate.


For the past four weeks, myself and other VM Stream users repeatedly reporting this via your VM forums have been unable to manage our packages online at – the page refuses to load. All other account pages are working correctly. Browser or platform makes no difference, nor does cache and cookie clearing.

Your first tier helpline has no idea what the problem is and seems badly trained in backend Stream issues. Forum moderators, though friendly, are providing no real feedback or acknowledging that there may be a common issue, asking the same unrelated questions no matter how carefully we explain what the problem is across different threads.

Example post threads are:


Tuning in

I get exactly the same issue and no one over the phone or on webchat will acknowledge the problem!

Hi 🙂

I have done as you said and made a complaint and used your wording, will be interesting to see if I get a response!

All the best