Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go app doesn't play recordings

Joining in

I'm on Android 14, on the same WiFi network as the TV box, and can watch live TV no problem. However, whenever I try to watch a recording, I get an error message saying "Not available. Sorry, we can't play this at the moment 1". Been happening for months now. I've cleared the cache and I've re-installed the app, but still no joy. Any help would be much appreciated!


Forum Team
Forum Team

Hi OliveClogs

Thanks for your post, welcome to the Community Forums. 

Sorry to hear you're having trouble accessing your recordings from TV Go. 

Can you please check something for us - if you click the person icon > Settings > Diagnostics, can you please check to see if an IP address is listed next to the CPE section? Or does it say unknown? This will let us know if your TV box is linked properly to the app.


Thanks Beth. I've checked the above and there is an IP address listed next to the CPE section.

Thank you for confirming @OliveClogs 

Can I also ask if you are able to view the recordings via another device at all or does the same error occur?

Joining in

The only other device I use TVGO on is my laptop, and its not possible to view recordings on that anyway, so I don't have any way of knowing if it's the same on any other device unfortunately.

Thank you.

Is it just one recording that isn't playing or all please? Do the recording work on your TV box itself?

Please pop back to us when you can. 

Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Recordings play fine on the box, it's just the app on my phone. None of the recordings work through the app.

Thanks Olive, so I can get a few more details from you I've popped you over a private message.