Showing results for 
Search instead for 
Did you mean: 

Unable to disable SSID Broadcasting on Hub 3

On our wavelength

I've just had a Hub 3 installed, replacing a Super Hub 2ac, to allow connection of my home phone service to the fibre network.

I've been setting things up and find I'm unable to disable SSID Broadcasting the option is greyed out in Hub3 Setting Advanced Settings -> Wireless -> Security. Is there something I can change so that I can alter the setting please?


Very Insightful Person
Very Insightful Person

Hi @Alan_H 

Please try the following

Advanced Settings -> Wireless -> Wireless Signal

Click on Disable Channel Optimization and then on Apply changes.

Then go back to Advanced Settings -> Wireless -> Security and you should be able to click the No box next to WiFi Network Name (SSID) broadcast

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

On our wavelength

Thanks but it doesn't help, the option is still greyed out.

Very Insightful Person
Very Insightful Person

1) I think you probably need to turn off smart/intelligent WiFi first

2) Why do you want to turn off the WiFi?


There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

On our wavelength


1. Is that not the "Disable Channel Optimisation" suggested by newappollo? That didn't work unfortunately, the boxes were still greyed out. Any further suggestions you have will be much appreciated.

2. It's something I've always done, since the very first router I ever had. I know it won't/can't stop a determined person from finding it, but it does mean that those who live around me don't know how many different networks, and their names, I have in my house. Where possible I prefer wired connections rather than wifi, so I have personal routers in the 3 rooms I use most (living room, kitchen and bedroom) that I can wire devices into. Only my phone uses wifi.

Hi Alan_H, 

Thanks for your post and welcome back to the Forums. 

I'm sorry to hear you're having trouble disabling the SSID broadcast. Information here should help you to disable this. 

Please pop back and let us know how you get on. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

On our wavelength

Hi Kath_F,

This is what I've already tried, and the option is greyed out, as per the below.

Screenshot 2022-09-11 131943.jpg


Hey Alan_H, thank you for letting us know I am sorry you are still having trouble disabling this.

I am going to send you a PM, as I can help you do this.

Please look out for the purple envelope. Thanks 

Matt - Forum Team

New around here?

I'm having the same issue, I've switched off Smart Wifi and still unable to disable SSID broadcasting

Hey @gforgabagool, thanks for reaching out to us and a warm welcome to the Virgin Media forums.

I'm sorry to hear you're struggling to disable the broadcasting SSID on the Virgin Media Hub 3.
I have attached a video here which shows how to alter, change, split and disable the SSID.
Let us know how it goes and if you still need assistance.

Kind regards.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs