Showing results for 
Search instead for 
Did you mean: 

Unable to reset password

Joining in


I am unable to reset my password as the password strength is classed as “invalid”, even when using passwords generated by a password generator. I am therefore not able to reset my password and access my virgin media account.


1. Open the MyVirginMedia app
2. Select “Broadband tv and phone”
3. Select “Forgotten … password
4. Follow the link provided in my email to the reset password page on
5. Try to choose a new password


No passwords are valid. Password strength is ”invalid” even when meeting the password criteria.


A password can be set and password for my account changed.


I am having exactly the same issue, can you help please??

Joining in

Having exactly the same issue, have tried different browsers and clearing cache and cookies, no luck - can someone help please??

Forum Team (Retired)
Forum Team (Retired)

Hi Samalo1661,

Thanks for your post and welcome to the community 

Apologies for the issues faced, can I ask is this for a newly installed account?



Joining in

I too cannot reset my password for my virgin media, i've tried different browsers and clearing my cache etc but it still won't accept my new password! This is for an account that is more than 20 years old!

Please advise?

Hi @bobbo

Thank you for your post and welcome back to our community forums. We're here to help.

I'm sorry to hear you're having some trouble resetting the password for the online account. Have you made sure that you're following this criteria?

•  Be between 8-64 characters.
•  Must start with a letter.
•  Contain at least one uppercase and one lowercase letter.

•  Contain at least one number.

•  Special characters are allowed but not required (e.g. ! # % & @).
•  Cannot contain easy to guess words, usernames, or previously used passwords.

Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

Ive got the same issue.  paying for virgin services I cannot use no tv on any device as no viable password 

Hi bluecaddy,

A warm welcome and thanks for posting on our community forums. Sorry to hear that you're unable to register for an account online.

Can you please ensure you are following ALL of the below criteria when choosing a password?

•  Between 8-10 characters.

•  Must start with a letter.

•  Contain at least one number.

•  No special characters.
If you are 100% sure that the above requirements are all being met, can we ask you to try some different password variations? This is because we've had reports of customers being able to proceed when doing this and it's mainly because some choices are too guessable to be allowed.
Can we also ask you to try registering through the Virgin Media app or through another web browser to see if this helps?

If this does not work, come back to us. 

Kind regards Jodi. 


On our wavelength

I have done all that is suggested about password reset and still getting password invalid.  Have now tried two browsers.  Please can someone help get this sorted out.

Hello BaH


Sorry to hear of the issues accessing the TV Go app, we have support here for assistance with this app, you can see here a list of the eligible devices and here is help on registering devices.


The log in details for TV Go should be the same as the ones used for your online account. Have you been able to set this up yet?



can someone please help! Having the exact same issue. No password will work, regardless of what combination I use, device or browser! Can’t log into anything