Showing results for 
Search instead for 
Did you mean: 

Netflix won’t load

Joining in

Our Netflix app won’t load. We just get the logo and then a black empty screen. 

it worked fine and we’ve already tried restoring factory settings but same issue. No connection issues as we’ve tested this via Netflix error menu that loaded. Netflix works fine on our other devices (connected to same wifi network as our tv box). Can anyone suggest any fixes? We’ve tried the usual resets, factory restore etc..


Very Insightful Person
Very Insightful Person

Hi Shughes1990 

Try the following.  Go to Home > Settings > Audio & Video >  Match Frame Rate > set  'match frame rate'  to Off

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Hi newapollo,

No joy unfortunately. This was already set to “off”. Toggled on and off again but still no joy. 

Netflix just shows error code “tvq-st-106” when we try to load. Said it can’t connect but Netflix works on other devices using same network so pretty confused. Spoke to Netflix support and they couldn’t help with the issue either so they told me to speak to the internet provider but I can’t see any connection issues at all..

Hi Shughes1990, thanks for the message and welcome to the forums. 

I am sorry to hear that you are getting the error code and this usually means that there is an issue with the connection preventing you to access the Netflix servers.

Can you ensure all cables are hand tight and do a pin hole reset to see if anything changes? 

Kind regards, Chris.  


Hi Chris. I tried this and Netflix did open but it didn’t load any images or information on the screen so still can’t use it. It appears to do the same on other devices (iPhone, iPad etc). Netflix loads but no images on screen and doesn’t feel like it’s fully loaded. 

I spoke to Netflix and went through all their troubleshooting but they said I need to speak to my internet provider. Netflix doesn’t either work at all or properly on any device connected to our Hub. When I disconnect from wifi on my iPhone and open Netflix using 4G all the images and details load fine. Any ideas? 


Hi @Shughes1990, thank you for your response.

Just to confirm, have you tried all the suggestions provided on this Netflix Help Center link here


H Daniel. 

Yep, tried all of those while on with Netflix support. They told me to speak to my internet provider. 

Pretty confused as my broadband connection is totally fine and other streaming services (Amazon Prime) is working totally fine. It’s as if there’s some way that Netflix isn’t picking up a service from my hub. Really frustrating and been a week without being able to access Netflix. 

Hi @Shughes1990 thanks for your reply here.

It's a possibility that the App itself is broken unfortunately, which would explain why everything else is working fine here.

This probably is a last resort as ultimately we'd look to replace the box anyway, but can you try to factory reset the box and see if this works?

Please bear in mind that this will delete all your saved recordings so as mentioned, it is a last resort.

If you are looking to do this, please see here on how to do so.

Many thanks


Hi Tom. 
We’ve already tried the factory reset on the box and no joy with it. Netflix app doesn’t work on our main tv box, it doesn’t work on our mini box in our bedroom, it doesn’t work via my PlayStation or via Netflix apps on either of our smart tv’s…. 

I can’t get a Netflix screen on any TV app. Here’s what happens when I try the Netflix app on my phone.

When I’m connected via my Virgin wifi (this is on my iPhone) 


 when I’m connected via 4G on my iPhone: