Showing results for 
Search instead for 
Did you mean: 

Superhub 3 only working at 100Mbs

Tuning in

I have upgraded to 350 Mbs. But all speed tests, even the one on Virgin Media site are reporting around 84Mbs.

My SuperHub 3 is connected by a 0.5m Cat 6 cable to a Deco S4 and is in Modem mode.

I have tried connecting by superhub Direct to laptop only with a 1Gb network port with a known good Cat 6 cable and it is still 100Mbs.

I have reset the Superhub, tried different ports on the Superhub, put the Superhub back into router mode and it's still the same.

Any idea?


Alessandro Volta

faulty hub then


Very Insightful Person
Very Insightful Person

Change the ethernet cable first - if it goes faulty (e.g. one of the little 8 wires snapped off in the connector) -  it will default to <100 Mbps


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Forum Team
Forum Team

Hi @happydundee 👋.

Thanks for reaching out to us. Apologies for the issues that you have been having with your speeds. Could you please run diagnostics on the Hub and perform some tests with the Hub in router mode removing all third party Hubs and post the results so that we can see how it is performing.

👉 Speed Test
👉 WiFi Diagnostic
👉 Slow Speeds Help

Keep us updated.


I have put Hub in Router mode. Connected my PC via Cat 6 Ethernet to the Hub 3, and this is the results. I am on 350Mb. I have done theSpeed Test Link and reset the router, I have done the WiFi Diagnostic and that is all fine. The result below is via a wired connection direct into my hub3 with nothing else connected.



If you read my post, you will see that I have already done this.

Very Insightful Person
Very Insightful Person

The Speedtest show a test server in Dublin and that does not look like a VM UK Speedtest. Are you in Eire?

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

See here, only my PC is connected:



and here:



See here, single device connected to Hub 3 at 1000Mb. so its not my cable: