cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi slow on MacBook Pro but fast on all other devices

labreumaia
Joining in

My internet is exceptionally slow (like so slow I don't even have the bandwidth to run a speed test) on my MacBook Pro, but fantastic in all other devices, including an iPhone, an Android phone and two PCs. The speed is slow regardless of where I am in my flat. It is a Virgin Media specific issue, as my internet speed is fine when I connect to any other wifi. I have already tried all the obvious steps:

  1. I have restarted the hub, to no avail.
  2. I googled it. It seems to be a relatively common issue with Virgin Media hubs and MacBook Pros – for example, see here and here – but none of the posts I could find provided a solution.
  3. I have reached out to Virgin Media support. They sent out a technician but the guy said there was nothing he could do, as it was a device-specific problem.

 

Any suggestions? I have a Virgin Media hub 5 and a 2022 MacBook Pro running macOS Ventura 13.5 (22G74).

1 ACCEPTED SOLUTION

Accepted Solutions

jbrennand
Very Insightful Person
Very Insightful Person

I have 5 Macbooks (including a Pro) of various ages and all connect perfectly at full speed.

What is connectivity like when you connect the Pro to the Hub via a Cat6a ethernet cable - use a USBc to RJ45 ethernet Adapter to make the physical connection

Some Mac issues have been reported on here - these are the ones I have collected - see if anything in these helps for starters

_____________________

No connectivity on Apple kit may be a MAC filtering issue for Apple devices - see if this has the solution for you….

https://community.virginmedia.com/t5/Networking-and-WiFi/Intermittent-iPhone-Apple-MacBook-amp-HP-Pr...
_____________________________
After a MacOS/iOS update, it may auto turn on Automatic Proxy Discovery for all Wi-Fi networks - so turn it off in network settings as per message 7. In iOs go to Settings>WiFi> tap the blue”I” icon and scroll down and make sure Configure Proxy/‘ is set to off - also that Configure DNS and Configure IP are set to automatic

https://community.virginmedia.com/t5/Networking-and-WiFi/Hub-5-macOS-Monterey/td-p/4885920

Cant connect as password is incorrect on iPhone (& Andrex)……. this sorted it…
https://community.virginmedia.com/t5/Networking-and-WiFi/Iphone-can-t-connect-to-Virgin-WIFI-Incorre...

Just moving SIM sorted it here

https://community.virginmedia.com/t5/Networking-and-WiFi/Iphone6s-will-not-connect-to-internet-via-w...


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

See where this Helpful Answer was posted

3 REPLIES 3

jbrennand
Very Insightful Person
Very Insightful Person

I have 5 Macbooks (including a Pro) of various ages and all connect perfectly at full speed.

What is connectivity like when you connect the Pro to the Hub via a Cat6a ethernet cable - use a USBc to RJ45 ethernet Adapter to make the physical connection

Some Mac issues have been reported on here - these are the ones I have collected - see if anything in these helps for starters

_____________________

No connectivity on Apple kit may be a MAC filtering issue for Apple devices - see if this has the solution for you….

https://community.virginmedia.com/t5/Networking-and-WiFi/Intermittent-iPhone-Apple-MacBook-amp-HP-Pr...
_____________________________
After a MacOS/iOS update, it may auto turn on Automatic Proxy Discovery for all Wi-Fi networks - so turn it off in network settings as per message 7. In iOs go to Settings>WiFi> tap the blue”I” icon and scroll down and make sure Configure Proxy/‘ is set to off - also that Configure DNS and Configure IP are set to automatic

https://community.virginmedia.com/t5/Networking-and-WiFi/Hub-5-macOS-Monterey/td-p/4885920

Cant connect as password is incorrect on iPhone (& Andrex)……. this sorted it…
https://community.virginmedia.com/t5/Networking-and-WiFi/Iphone-can-t-connect-to-Virgin-WIFI-Incorre...

Just moving SIM sorted it here

https://community.virginmedia.com/t5/Networking-and-WiFi/Iphone6s-will-not-connect-to-internet-via-w...


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

labreumaia
Joining in

Thanks, John. This was helpful. After playing around a bit I found what the actual problem is: the Virgin Media router for some reason doesn't like it when the “Limit IP address tracking” option is on. I simply turned it off and the connection is back at full speed.

jbrennand
Very Insightful Person
Very Insightful Person

Are you using the Hub5 in normal router mode - or have you got your own Router.  If so - what make/model?


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.