Showing results for 
Search instead for 
Did you mean: 

Virgin Hub 5 won't work in Modem Mode

On our wavelength

Hi everyone - I need your help before I lose my sanity.

Upgraded from M500 to 1Gig broadband with Virgin when I recontracted a couple of weeks ago. I previous had a Hub 3, running in modem mode with my own Linksys mesh wifi hardware. All worked perfectly.

Received the Hub 5 as part of the 1Gig upgrade. swapped that out OK, put it into modem mode, and that too worked just fine with the Linksys hardware.

Yesterday I tried to replace the Linksys hardware with a new trio of Tenda MX15 Pro mesh units, and hit no end of problems. Disconneded the master node of the Linksys setup from the Hub 5 and connected the master node of the Tenda. It refused to flat out to communicate with the Virgin hub in modem mode (I was connected to port 1 on the Virgin Hub, and Port 1 on the Tenda, so definitely the right Ethernet ports). Switched back to the Linksys, wouldn't connect to that either now. Rebooted, no different, reset and reestablished modem mode, still won't work. Even dusted off my old TP-Link wired business router, refuses to talk to that either (and that was also used with the Hub 3 without issue).

I've reset the Virgin hub again, and am currently running it in router mode, and daisychaining the Tenda Mesh off of it as a secondary network (not ideal, and my wireless Sky Q boxes don't like it like that, they want a more direct connection. It's the only way I can get any of my wireless hardware (or indeed the wired router) to get an IP address and a connection from the Virgin hub.

I remember back in my Blueyonder days, that the Motorola cable modem needed to be manually disconnected from the MAC address of the network device (computer, router etc) it was attached to before you could connect it to something new. Could it be that? If so, how on earth do you do it. Blueyonder used to have a web site for it I believe, but no sign of an equivalent these days and nothing on the Virgin Hub to do it.

Does anyone have any idea what might be the issue and how to resolve it please? Thanks


Community elder

Did you reboot the HUB after connecting the Tenda?

In modem mode only one wired device is provided an internet connection. The HUB 'latches' onto a device's MAC address to identify which device should have internet access. Even if you swap the wired device the HUB won't provide an internet connection unit the HUB is rebooted to 'latch' onto the MAC address of the new device connected to it.

Another thing to note is you'll lose some of your bandwidth due to the 1Gbps ethernet ports on the Tenda. Essentially you'll me limited to around 940Mbps, rather than around 1130 - 1152Mbps, across all your devices.


Alessandro Volta

2mins with hub off when in modem mode to allow new MAC 


Hi Carl

Yes, I did reboot after connecting the Tenda in modem mode (same operating process I used to do if changing third-party router with the Hub 3). Made no difference sadly. Same when I tried to switch back to the Linksys or the TP-Link. Using the Hub 5 as my actual wireless router is a no-go as 1) signal is poor and 2) it can't cope with more than 30 connections (I have a lot of smart home tech). That's why I always put the Virgin hub into modem mode and use third party hardware with better WiFi and capable of handling more concurrent device connections.

Also, I realise I'll lose the top end on the bandwidth, but I'm OK with that (not worth upgrading my setup to 10Gig, all my ethernet is Cat 6 with a 1GB 24-port switch at the core).

Very Insightful Person
Very Insightful Person

You must follow the correct sequence when you change your own router. I’ve had to do this many times when I changed my router. 

How to put a VM hub into modem mode:

1) Access your hub on, sign on and put it into modem mode. On the Hub3 the bottom LED will change to magenta, on a Hub4 the LED band will be green, on a Hub5 the LED will be green. Best done from a wired connection.

2) Turn off the hub and disconnect any Ethernet cables

3) Fully initialise your own router or mesh master unit and make sure the WAN port is set to DHCP (for some routers or mesh this may have to be done in router mode before entering modem mode)

4) Connect your router or mesh master unit to the VM hub with an Ethernet cable, Cat5e or Cat6, any higher specification is a waste of money. On a Hub5 use port 4.

5) Turn on the VM hub.

6) You should now be able to access the internet and the hub will now be on

Note1: this only needs doing once for each new router or when VM changes your WAN IP address.

Note2: If you have a Hub4 and your own router is NOT then it’s possible that you can still access the VM hub on

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Hi Tudor

To be absolutely sure, this evening I've followed your steps above meticulously - doesn't work! The Tenda still won't connect to the Virgin Hub when it is in Modem mode, only in router mode.

That said, again using the same steps, I can't get anything to connect to the Virgin Hub in modem mode, including my previous mesh WiFi hardware or my wired router.

Something is clearly very very wrong with the Virgin Hub - I fear a wasted day tomorrrow on the phone trying to explain this to an offshore call centre rep who won't have a clue what I'm talking about.

No - didn't work!

On our wavelength

Actually - scratch that - I have been able to get my wireless router working again with the Hub still in Modem mode. Leaving it alone for the night as we need some internet access again, going to retry tomorrrow. But starting to think part of the issue might be the Tenda units themselves.

Community elder

It appears the default setting for 'Internet Connection Type' on the Tenda is 'PPPoE', when it should be set to 'Dynamic IP'.

I have it set to Dynamic IP. The MX15 Pro doesn't default to PPPoE, it runs a connection test to try and detect it, and if it can't its asks you to choose.

For tonight, I've put the Tenda kit into AP mode, and letting the TP-Link wired router run the network. It's working, but its disappointing the Tenda and Virgin kit won't talk to each other. Eyeing up a potential replacement Mesh kit from TP-Link (Deco XE75 AXE5400) - it's 5400 like the Tenda MX15 Pro, but tri-band rather than dual-band and 6E rather than 6.