Showing results for 
Search instead for 
Did you mean: 

Smarthub working on wired connection but not wifi

Joining in

Very recently (Tuesday 9th April) I started having issues connecting to my virgin hub via wifi. I can still see the two networks (5g and 2.4). First was my iphone which started saying 'weak security' then showing a progress wheel next to the network and failing to connect.

I connected my macbook via ethernet and everything worked fine. My PS5 also connects via ethernet over powerline adaptors and that remains unaffected. Our Sonos and Amazon firestick which both operate on wifi have stopped working.

My laptop connects to the 5g network but has no internet, it says it has a self assigned IP and I've tried renewing DHCP, turning wifi on and off on the laptop, no joy.

No flashing lights or anything on the router itself. Light at the bottom is normal slightly off white colour and the green wifi symbol is steady.

I've not had much time to troubleshoot so far so will hard reset the router this evening. Any ideas beyond that though?



Connect to the VM Hub at  find out if the Internet is Online, 
check if the Wireless is enabled for both 2.4 & 5 GHz.

Weak Security often means that WPA-PSK needs to be Disabled
in the VM Hub Wireless Security settings.

Alessandro Volta

Look to get a better wifi router with 1Gb ports and put hub in modem mode


Forum Team
Forum Team

Hey matwandless, thank you for reaching out and a warm welcome to the community I am sorry to hear this.

Did the advice about WPA help at all?

Normally once disabled this setting this will disappear. 

Matt - Forum Team

New around here?