Showing results for 
Search instead for 
Did you mean: 

Re: Extremely bad latency issues. Cannot make video calls.

Just joined

Have the exact same issue - and I have figured it out, go into the Router settings and disable 'channel optimisation'. And boom, perfect video calls again. Virgin refuse to admit there is an issue with it, but it makes sense to think that when on a video call, the router is switching channels 'trying' to get the best connection but actually has way too much loss in signal to be effective. I disabled it and no issues. Only downside now is that the mesh pods only work with optimisation on, which is ridiculous. So it's a lose lose, totally unstable video calls literally a few feet from the router or not enough signal strength for the whole house. Only option for now is trying to get the newest Hub 5 from VM (which I'm sure they will not give me) or else buy a decent TP-Link router and see if that does it all. 


Very Insightful Person
Very Insightful Person

All VM Hubs, including the Hub 5 use Smart Optimisation and as you know it is necessary for the Pods.  It's all part of the "Intelligent Wifi Solution" 

Personally I (and lots of users here) use modem mode and my own Wifi solution of PoE Access Points and those I have full control over.  It may be something you should consider.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks


I totally support the sentiments of invest in your own Wi-Fi network & maintain full control over it.