Showing results for 
Search instead for 
Did you mean: 

Hub4 & Connect app

On our wavelength

Hi from a very frustrated user as I have tried all suggestions given but nothing has worked.

That includes pinhole resets & normal reboots.

I have lost count of how many times I have uninstalled and reinstalled the app. As far as the hub is concerned I can get the Internet OK either using WiFi or cable. The problem with the hub4 is that the app cannot find it and nor can I connect to it either with cable or wifi using 

I had this problem ages ago but the hub then done a reboot one night and was then ok but recently I saw it do a reboot all by itself during the day and since then the app cannot find it nor can I using

I have tried all suggestions given but nothing at this end has worked so either the hub4 is faulty or it is something back at VM.

Can someone give me the solution to this problem.




Forum Team
Forum Team

Hi Grumps70,

Sorry you're still having some issues seeing the hub via the app.

So I can get a few more details from you I've popped you over a private message.



Regardless of what the VM notes may say ...

Press the RESET button for 60 seconds, then leave the Hub 4 powered on to revert to the factory option.

Less than 60 seconds will not trigger a full reset.

On our wavelength

Have done that more than once. Even had a timer on it. Am now in comms. via pm. Just waiting to get another reply.


You need a replacement Hub.  

If there are any issues with VM support, turn the Hub 4 off, then call in an report it has failed / is totally dead.

Joining in

I have this exact issue too. Connect app used to work but a few weeks ago, stopped. I’ve done multiple factory resets including the 60 second one, left it turned off all day, reinstalled VM Connect multiple times. No good. Can’t get into the hub at either. 

On our wavelength


I have now had a visit from an engineer who changed the hub as they could not access it either with

All is working fine at this end now apart from the hub not connecting with a pod. This they have to do at their end to re - pair the hub and pod.

I have now ditched the connect app and will not use it again. 

After posting on here a few times about my problems the vm team sorted things out but it can take a bit of time.

Hope you get sorted OK.



Dialled in
  1. There is an issue with connect App and HUB 4, (VM seem very very slow to resolve).
  2. The HUB is faulty this seems most likely as you have done everything to resolve the access issue.

VM Connect  App  "we cannot find your HUB" so you (VM) lost it send me a new one !! 🤣🤣🤣🤣🤣

Request/demand a replacement HUB - 

Dark Knight

On our wavelength

They changed the hub 4 to hub 5 yesterday and all is working fine apart from the hub will not pair with a pod. This they say can only be done at their end. They tried yesterday but did not work so hopefully they will be able to do it today.

Have a good weekend 

Spent hours on phone to VM and got nowhere. Spoke to someone on the X support and after much toing and froing finally told there is an issue with app!!!  Poor communication and slow response to resolve issue