cancel
Showing results for 
Search instead for 
Did you mean: 

HELP!! Connect app Sorry We couldn't connect you to the server. Please try again in a moment.

cdagnan
Joining in

Some time last year my VMConnect app stopped recognising my login/connecting to the server... I get as far as a red topped white screen on my iPhone that says:

Sorry! We couldn't connect you to the server. Please try again in a moment. (Try Again)

It did this around when I set up the device for that biometric login thing. Any how I've now had enough and have tried to sort it out.

From my main computer I have removed the two devices showing as biometrics.

I know the password is right...co I log in ok with it on my main machine.

On iPhone - fully deleted the VMConnect app. hard  reset phone. reinstalled app. turned off the mobile wireless so only WIFI in use.

opened the VMconnect app gone through the accept terms and conditions page, gone thru the 'app wants to use auth.virgin.whatever to log in' page entered password....

then app asks if I want to set up the biometrics thing - I click no just use password....

then it says Sorry We couldn't connect you to the server. Please try again in a moment.

tried several times today - repeated the delete and reset etc... even turned off the 'allow to use mobile data setting' to force it to use my WIFI...

my WIFI is working fine - but I cant get the app to connect to server... and the app is not listed in apps using iCloud either.

HELP PLEASE MAKE IT WORK!

11 REPLIES 11

Client62
Legend

Save a lot of trouble and ditch the VM Connect app.

Manage the VM Hub at http://192.168.0.1/   login with the Hub Password.

Ayisha_B
Forum Team
Forum Team

Hi @cdagnan 

Welcome to our Community Forums and thanks for your post.

Sorry for the issues you are experiencing with the Connect App.

The first thing to be aware of is you need to be connected to your Home Wi-Fi. It won't allow the connection if you're on a different Wi-Fi network, Guest network on your own Wi-Fi, VPN, or mobile data. If this still doesn't help, try clearing the data within the Connect App. These steps will help you do that:

For your Apple device, if you're on iOS 15 then you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.
If you're on iOS 16 then just delete the app from your device, restart the handset, and then re-download the Connect App. 

For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache. 

Let us know how you get on.

Ayisha_B
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Already done all of that - several times - no joy.

Good evening @cdagnan 

Thanks for coming back to the thread and confirming.

Can you confirm if you have a VPN on the device? If so, you'll need to remove it for the Connect App to work.

John_GS
Forum Team


Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

cdagnan
Joining in

I do not have VPN. it all worked fine until it tried to set me up with extra security - can't remember the name - but it wanted to use facial recognition or something - since then - always the same. error

 

Client62
Legend

Remove that extra security, it could well be that is the root cause of your problems.

cdagnan
Joining in

already done that...

Hi cdagnan

Just to confirm, are you redirected to a webpage when you sign into the Connect App? If you have any screenshots you can send over of the journey you're having when signing in, that would be great. Please, of course, ensure to remove any credentials from these screenshots.

Thanks

Beth

cdagnan
Joining in

IMG_2073.pngIMG_2074.pngIMG_2075.pngIMG_2076.pngIMG_2077.pngIMG_2078.pngIMG_2079.pngIMG_2080.pngT

 

These are from opening the app - to giving up. - there's a step in the middle where I enter password - email address is already stated - both are correct as I use them to log into account on the web with them.