cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting Sonos to Virgin broadband

urban_spaceman
Tuning in

Hi there. Am really hoping someone can help me!!!

We have recently moved home and had Virgin Media broadband installed with the “Hub 3”.

However my Sonos is not connecting to it.

The Sonos app is saying that if a router supports both 2.5Ghz and 5Ghz then they need to be split and renamed. I've tried this - I think - by going into the router settings then into Wireless then security and giving both different names. No joy.

One at a time I have also disabled each and tried, but again no joy.

Can anyone help at all please?

Thanks a million.

38 REPLIES 38

SimpleSimon
Superfast

urban_spaceman
Tuning in

I have yes but it won't connect. The troubleshooting messages that caused me to take the steps detailed above are ...

WhatsApp Image 2023-06-01 at 20.44.19.jpegWhatsApp Image 2023-06-01 at 20.44.16.jpeg

g0akc
Problem sorter

Are the renamed SSIDs (network names) showing correctly (shining okay)?

  • In the hub settings check that you have renamed them and it has retained the setting - with, say, VMXXXX2 and VMXXXXX5
  • Then use a free Wifi Analyser app and see if you see them both correctly.  You should also be able to see them in your device's list of available networks (check with a smartphone or whatever).
  • Often VM software updates or bugs mean that the hub reverts to a single SSID - hopefully this won't be a problem once your equipment is connected - but maybe keep one of the SSIDs as standard and only rename one of them or the connection might be lost.
------------------------------------------------------------------------------------------------------------------------------
I know a bit about Wi-Fi, Telecoms, and TV as I used to do it for a living but I'm not perfect so don't beat me up... If you make things you make mistakes!

Hi there. It's definitely retaining the settings and "shining". Still no joy though 😞

Client62
Legend

Make sure the 2.4Ghz WiFi of the Hub is set to B/G/N mixed mode as per the Sonos instructions.

urban_spaceman
Tuning in

I've followed the Sonos instructions and it's still not connecting.

 

Here's a screenshot of the Wireless signal settings:

 

Screenshot 2023-06-05 at 21.16.10.png

Adri_G
Forum Team (Retired)
Forum Team (Retired)

Hi urban_spaceman, thanks for reaching out on our help forums and welcome to the VM community. 🙂

We're sorry to see you've been struggling with connecting your Sonos speaker to the new hub 3 and VM network.

We'd love to best help with this, from what we can read above you've tried to split the frequencies and follow the advice from the Sonos App without luck so far.

Have you switched the smart Wi Fi feature off (channel optimisation off) on the hub settings when amending these to ensure the changes will stay on? 
(Channel optimisation is set to switch back to the smart wireless default settings if on).

Have you by any chance tried to switch to WPA instead of WPA2 option for security as your hub should be on by default at the minute to see if this helps?
To make this change, go to advanced settings>wireless>security and opt for WPA protocol instead of the WPA2 one.

Once you save this, see if refreshing the Wi Fi connection with your speaker works this time.

Lastly, could you please tell us what error you get when attempting to connect your Sonos to the Wi Fi so we can advise more?

Please, share these and we're here to assist further where needed.

Adri
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Hi Adri. Thanks for replying and sorry for the delayed response, I have been away with work.

 

In the meantime we were upgraded to a Hub 5 but unfortunately we are still having issues with Sonos.

 

The Sonos now connects to the WiFi but we can't use Alexa to play music (through any player: Amazon Music, Spotify, etc).

 

The router settings are as per above - ie we have given 2.5 & 5 GHz separate names.

 

I have also followed your advice by switching off smart Wi-Fi however a) this didn't resolve the issue, and b) it meant that other devices (eg my TV) couldn't connect to either 2.5 or 5.

 

Also I am unable to switch from WPA-2 to WPA as there is no option for this. The available options are WPA2-PSK, WPA3-SAE, or WPA2-PSK/WPA3-SAE.

 

Would really appreciate more help. Thanks.

Adduxi
Very Insightful Person
Very Insightful Person

The Hub 5 is has the newer wifi 6 AX protocol, so some older IoT can cause problems.  Check as below and set the 2.4Ghz to legacy;

Access your Hub by navigating to 192.168.0.1
Login with the default login info (on base of Hub) unless you've already updated it.
Go to Advanced Settings > Wireless > Wireless signal
In the Wireless frequency 2.4GHz select Wireless mode > 802.11b/g/n/ax mixed
Select Apply changes

If all fails, you could try a basic 2.4Ghz wifi extender, connect this to the Hub and connect the Sonos to the basic extender.?  Something like this Buy TP Link 300Mbps Universal Wi-Fi Range Extender | Wi-Fi boosters | Argos

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks