Showing results for 
Search instead for 
Did you mean: 

Cannot login to Connect App

On our wavelength

I received a new Hub 3.0 yesterday and whereas I could previously use the Connect app to measure hub and device speed, it no longer connects to the hub.  I have ceared cache, removed and re-installed app but sti not recognising the hub so it sees this issue has not been resolved.


Forum Team
Forum Team

Hey @dickeverard Thanks for reaching out to us on the Virgin Media forums. 👋🏼

I'm sorry to hear about the issues with the Connect App you are facing. 😢

Please try the following:
For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data. 
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.

If you are using an Android device can you please ensure you have the following settings enabled:
Location Permissions (Settings > Apps > Virgin Media Connect > Permissions)
Nearby devices (Settings > Google devices & Sharing > Scan for nearby devices).

Let us know how it goes. 🧾

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Usually it takes a few days to a week for the VM Connect to work with a replacement VM Hub.

Forum Team
Forum Team

Hey @dickeverard,

Can you please confirm if you've been able to make any progress on this matter?

If you're still not able to sync the Connect App to the hub, do please see if a pin hole reset on the hub - via the reset hole on the back of the hub - held in for 60 seconds does the trick.



Didn't help still not working.

It is over a week and still not working.

I did a reset earlier today but VM Connect is still not working.

Thanks for coming back to us @dickeverard, if this matter is still ongoing, can you please sent a screen shot of the error you're being presented with on the Connect App?

Please ensure that an account specific/sensitive information is edited out of the picture as this is an open platform



I attach a screenshot but you should be aware

Screenshot_20240424_183221_VM Connect.jpgthat Virgin decided to give me a new Hub 5 today.  So maybe I need to wait another week.

Do you have any other devices you can test it from? @dickeverard 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs