Showing results for 
Search instead for 
Did you mean: 

Cannot connect to Hub 4 Router via IP Address. VM Connect cannot find router.

Tuning in

Had Hub 4 for maybe 2 years. On and off issues. Then  2 days ago I try to access the router to switch off 5g to add a 2.4g Wifi plug and cannot connect to the router ip address. After many attempts get to the password page, sign in and it's simply a blank white screen. 

VM Connect app wouldn't start at all, then occasionally tries to get the info. But never finds the hub. VM Connect has NEVER actually worked. Occasionally it finds the devices, but immediately reverts to 'Hub not found". Mostly it goes immediately to "Hub not found'. Which is ridiculous. 

Full WiFi no issues. Ethernet cable for desktop Mac. Fully up to date. No iPhones can connect to ip address either.  I don't have access to android phones to see if any difference. Not that there should be. 

Tried rebooting. Tried hard reset router via pinhole for 60 seconds. Tried switching everything on and off and reconnecting any ethernet cables over and over again, to no avail. Cache's deleted. Apps re-installed. nothing works. 

Help line -  spend HOURS waiting to be transferred to "tech team' for which I am told I may well be charged. Didn't even get through. There's only so long you can spend waiting on a phone and we are talking hours. 

Not impressed with the service. Been a customer for 16 years - since the beginning. Telewest before then!

Any suggestions?



The Hub 4 Admin menu has failed ( Hub 4 may also be failing ) , the symptoms are one or more of : 

1) Admin menu shows white screen
2) VM Connect app that was working not fails
3) VM Connect app may get stuck in a Optimize Wi-Fi loop.

Perform a 60 second press of the RESET button, then leave the Hub powered on to perform a factory reset,
the Hub 4 will revert to the shipping condition and to the passwords on the bottom sticker.

Hi Client62. 

Firstly thanks for taking the time to reply. I have previously carried out  your suggestions (and many others per the forums). So Far nothing has worked. Interesting that the HUB 4 may be failing. I mean getting solid Wifi signals and internet signal is sound. So when you phone Virgin - they are like "No problem our end - here's the number for the PAY TO GET HELP Tech advice"! 

Maybe just send out a new HUB? 


If at the time you call VM it appears like the Hub has failed and is offline that can help to get an engineer out.

Hint  ... the remote system tests can not tell the difference between a failed Hub and a Hub that is powered off.

Tuning in

Well it looks like it's about to chuck it....


With Purple Rain ?

Tuning in

Like Hamlet and shuffle off this mortal coil!

Everything you have said is exactly what is happening to mine,  VM won't help

And they never did help me. Actually they tried to pass me to a ‘pay for’ tech support. As it happens i had run out of time dealing with this and had to attend to other matters in my life beyond waiting FOR DAYS for Virgin to fix something we pay them handsomely for! Anyway the matter resolved itself. The problem simply went away after about 4 days. I did notice that there was mention of work being carried out due to a service issue.  But there was no detail of it anywhere other than on a pre-recorded message. All services showed green.  

It’s the only thing I can think of. But I am absolutely sick of the customer service. I personally feel they have an unfair  monopoly on cable. I do not understand how this is allowed. 

Thanks for the update @PraetorianPhil, and I'm sorry to hear of the recent issues experienced on the connection.

Pleased to hear that this is currently operating to the expected standard. 

Do however please report back to us if this issue re-emerges and we'll be on hand to assist where possible.