Showing results for 
Search instead for 
Did you mean: 

Can’t access Hub 4 settings page


Hello, as I can see many people have this issue, unfortunately I have it too. I can’t access the settings page for the Hub 4. Blank page once I put my password. I tried all the suggested solutions but to no avail. Can someone from Virgin get in touch and help me with this please. Thank you


Forum Team
Forum Team

Hey loanaNeacsu, thank you for reaching out and I am so sorry to hear about this.

What device are you using when you are trying to access it?

Have you tried to use another device at all? If not can you please try this.


Matt - Forum Team

New around here?

Hi, I used different devices and browsers, an iPhone with Safari, a Samsung with Chrome and a Huawei with Opera. All of them did the same, after inserting my password it gives a blank screen. I can see this is a wider issue, maybe VM needs to do something g at their end and force an update on the Hub 4 for all of us having this issue. I can see that the suggested solution in the forum to press the reset pinhole for 60 seconds doesn’t work. So, we need a solution to this issue.

Hi @IoanaNeacsu, thank you for your response.

Given a pinhole reset hasn't rectified the problem, we'll need to arrange a replacement Hub for you. 

In order to discuss this with you further, we'll send you a private message on here. Look out for the envelope in the top right-hand corner.

If you're on a portable device with a smaller screen, click on the icon in the top right-hand corner and select "messages" from the additional menu options.