cancel
Showing results for 
Search instead for 
Did you mean: 

Red light Hub 3

Sazdaz
Joining in

Hi we have a constant red light in our hub, Wi-Fi is poor and Ethernet ports now not working as well. We can’t get through on the phone and last time we did we were told we all was working fine when it wasn’t. We’ve reset 3 times and problems persist.  Please can someone from virgin  contact us we need an engineer to visit or at least a new hub. Thanks 

10 REPLIES 10

Vikki_M
Forum Team
Forum Team

Hi Sazdaz

Thank you for your post and welcome to our community.

We are sorry to hear about the red light on your hub.

Please kindly try the below steps.

• Turn the power switch off on the back of the Hub. 

• Ensure the Hub is upright, in a well-ventilated location, and, if at all possible, out of direct sunlight. 

• Then use the power switch to turn the unit back on. The Hub should now operate normally. 
 
If after following the above steps the router doesn't boot back up after a few minutes, or the red light returns when it does, then the router will need replacing. Please let us know and we can take from there 🙂
 

Vikki - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


Hello. We have tried all of the above several times and still have red light. Please help!


@Sazdaz wrote:

Hello. We have tried all of the above several times and still have red light. Please help!


If its definitely red after repositioning/rebooting then its indicative of an overheating issue. I say definately red because the LEDS in these HUB3 are so cheap that they can be more pink (when originally magenta) or orange tint.

See here:

https://www.virginmedia.com/help/how-to/broadband/hub-lights

Specifically your issue: https://www.virginmedia.com/help/how-to/broadband/hub-lights/red-solid-power-light-hub-3

 

Sazdaz
Joining in

Thanks for your help. We’ve tried everything. I am seriously hoping one of the virgin team come back to this thread to arrange some help for us as we are at our wits end with it. 

Is there anyone from the virgin team out there to help please?  Although I said the previous post was helpful it had NOT solver our problem. 

Hi there @Sazdaz 

Thank you for trying the reset and we are so sorry this did not resolve things. 

I will pop you a private message across so we can arrange an engineer to come and take a look. I will pop you a PM across now, please keep an eye out for the envelope at the top of your screen alerting you to a new message.
 

deadman_uk
Joining in

Same issue here, red light on my Hub 3 for over half a year.

Hi Virgin team. Received and replied to your PM on Friday but we have heard nothing since! Please can someone let us know by PM when we can expect an engineers visit. Thanks. 

Update to my post. We ended up enduring another call to the call centre last Sunday as nothing was working properly . They tried to tell us that the red light was normal and they were just experiencing intermittent problems with hub 3s. Also said that they could make changes remotely to our hub that would solve things. They would not book an engineer for us. Hubby was sick of it and had to really insist that they either send an engineer or a new hub. They gave in and booked an engineer who walked in and promptly said it needed replacing as the red light means it’s overheating!  The engineer was great.  New hub means everything is working perfectly now and we don’t need our booster any longer. Wish we had insisted long ago.