Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go App not working after the recent upgrade

Joining in

Since the recent upgrade to the app, I now get the message 'If you'd like to watch this programme, please call us on 0800 052 0701 to upgrade your Virgin TV package'.

This app has been working for years, and as far as I know I'm on the top package. The TV Control App works fine.

I have a V6 box and am trying to use the app on various IOS devices, all with same issue.

I've tried to get this issue resolved via online chat, but as usual that doesn't get it fixed, so I'm hoping the Community route may find a solution.

I'm assuming it's something to do with the app being setup for a 360 box, rather than v6, but who knows. All I know is that it stopped working after the upgrade.

I've deleted the app and re-installed it numerous times on different devices, and rebooted the V6 boxes and hub lots of times too.

Any assistance would be good at this point!

Thanks in advance...


Forum Team
Forum Team

Hi mpfc6324

Thank you for your post and welcome to our community.

Were sorry to hear about the issues you are having with TV GO. 

Are you getting this error message no matter what programme you select?

Or is this just on certain features?

If so, please let us know which channels this is happening on.

Please pop back to us when you can. 

Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Hi Vikki,

Thanks for getting back to me.

As an example, I can watch 'The Super Mario Bros' movie on my TV V6 box with no problem, similarly I can watch 'The Blacklist' via on-demand.

I recorded this film and can watch it via the TV Control app without a problem.

Whereas, if I try via the TV Go app I get the 'If you'd like to watch this programme, please call us on 0800 052 0701 to upgrade your Virgin TV package' message.

I've added some screenshots showing the above problem, and the profile I set up to see if it worked that way, but that seemingly makes no difference.

Hope this helps to diagnose the issue




Hey @mpfc6324,

Thanks for confirming this for us, we would like to go about looking into this further, for us to do so we will need to confirm some information from you in a private message.