Showing results for 
Search instead for 
Did you mean: 

Virgin Go App

Joining in

When I try to watch my recordings on my Virgin TV Go App, it keeps saying " Sorry, we can't play this at the moment 1" 

How can I fix this?


Forum Team
Forum Team

Hi @Broady96 👋.

Thanks for reaching out to us. Apologies for the issues that you are having with the Virgin TVGO app, can I ask, since your post has this issue been resolved or are you in need of further assistance. Please let us know. 


The issue has still not been resolved. I am still having the same issue unfortunately 

Forum Team (Retired)
Forum Team (Retired)

Thanks for coming back to us on this Broady96 🙂

When you're using the TV:GO app, are you attempting to watch the recordings whilst connected to your home network? In addition, do you get the same error messages on all devices you have connected?

Can you also confirm for us the make and model of your device, along with the current operating system, and version, and can you confirm that the TV:GO app is fully up-to-date?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ