Menu
Reply
cantlogin
  • 4
  • 0
  • 0
Joining in
6,652 Views
Message 1 of 39
Flag for a moderator

Cant login to Virgin TV GO

I can't log into TV Go via the app on either ipad or android or via browser. I can login perfectly fine to myvirginmedia and my mobilemyaccount. I can even select the Virgin TV GO link via my virginmedia which takes me to the TV GO sign in. On the ipad I'm running Ios 12.1, I'n uninstalled and reinstalled the app (incidentally seems unstable at times and flashes/flickers badly).

I get a username or password incorrect error and then asked to click on the I'm not a robot link which just seems to present you pictures to click for ever without doing anything

I've spent the past 2 fruitless hours on the phone getting bounced around and getting through to second line technical support (eventually!!) only to get dropped before they could root cause. 

Anyone else got this problem. I see it pops up periodically but I am completely locked out on any platform.

 

I don't want to waste any more of my life on this but considering I'm spending >£130 month with Virgin the is **bleep** poor.

Fraser

0 Kudos
Reply
Rose_B
  • 9.51K
  • 397
  • 530
Forum Team (Retired)
Forum Team (Retired)
6,603 Views
Message 2 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

Hi Fraser,

Thanks for posting and I'm sorry to hear about what's happened.

I'd like to look into this for you so I'm just going to send you a private message which you will find if you click on the purple envelope at the top right of the screen.

Talk to you soon

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
cantlogin
  • 4
  • 0
  • 0
Joining in
6,586 Views
Message 3 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

Having got the problem solved I should probably give an update.

So bear in mind my login and password was always correct naturally one is nonplussed when  your login and password is rejected and you  are then told to click on the "I am not a robot" button and then select multiple images of shopfronts or traffic lights...screen after screen. This I did but frankly by the 4th or 5th screen I just aborted - well why wouldn't I, I'm already thinking something is broken and I'm not stuck in an endless security loop.

Thankfully the second line line support guy who I got through to after 2 hours of phone calls did persevere and to whom I had given my login and password and hey presto it actually worked.

Ok, so you could blame my stupidity for not keeping going buy I think there are two issues here and I could be excused for what happened.

1) Clearly Virgin had not fully tested the "user experience". I don't know quite why the "I am not a robot" security layer was so over zealous. I think 2 screens max should have been what I was displayed with not half a dozen. One could also ask the question. If my login and password was correct why the heck was it rejected in the first place and why was I subjected to this idiotic security protocol.

2) This scenario was clearly not in the first line support playbook. But then again if they had tested the user experience out as per #1 then it would have been.

So the next time on any app you get asked to identify all the squares with a  shop front etc.....just keep going...and going....and going....and just maybe the application will let you in.

Fraser

PS At least it is gratifying that Rose_B who seems to work for Virgin is monitoring the forum and private messaged me in an effort to resolve. Next time though...just make sure the application is tested from the user point of view.

 

0 Kudos
Reply
aIIan
  • 4
  • 0
  • 0
Joining in
6,561 Views
Message 4 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

Yep same thing here,

Most times when I try to sign into My Virgin Media page its murder trying to get it to accept your details .

Then you get  I Am Not A Robot pages again and again only for it again not to accept you, so again you have to go through all that rigmarol

last time it took 10 attempts

I have had this problem ever since Virgin started and as I rarely used it I always thought it was my fault

Something wrong with my password was my assumption, but now I know its not me just this stupid sign in page 

( From what I gather its not your password, its Virgin not recognising your email address, it has trouble finding your details)

Perseverance pays out if you can be bothered.

 

0 Kudos
Reply
mmbentley
  • 1
  • 0
  • 0
Joining in
6,540 Views
Message 5 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

I have the exact same problem with the Iam not a robot check box keeps on reloading withot confirming anything.

0 Kudos
Reply
nikyb25
  • 3
  • 0
  • 0
Joining in
6,145 Views
Message 6 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

everytime im trying to log on it says log in using your main user account sub accounts cant log in ive spent all morning on the darn phone being passed ffrom pillar to post and quite frankly i am very annoyed because three tech people hung up on me 

0 Kudos
Reply
Martin_N
  • 5.29K
  • 223
  • 302
Forum Team
Forum Team
6,129 Views
Message 7 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

Sorry to hear of the problems you're having nikyb25. 

 

Have you had any further luck with this?

 

^Martin

0 Kudos
Reply
nikyb25
  • 3
  • 0
  • 0
Joining in
6,127 Views
Message 8 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

no its still not letting me log on it says please sign in with your main user account sub accounts cant be used but ive used my main account user name 

0 Kudos
Reply
Martin_N
  • 5.29K
  • 223
  • 302
Forum Team
Forum Team
6,124 Views
Message 9 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

Are you able to sign into your online account without issue?

 

^Martin

0 Kudos
Reply
nikyb25
  • 3
  • 0
  • 0
Joining in
6,121 Views
Message 10 of 39
Flag for a moderator

Re: Cant login to Virgin TV GO

yes it lets me log into my virgin media just not tv go 

0 Kudos
Reply