Showing results for 
Search instead for 
Did you mean: 

Can’t download on virgin go app (Under Investigation)

On our wavelength

I have been trying to download movies to watch offline on the Go app but just get a message saying download’s temporarily unavailable. 

I have been trying for several days on both my iPad and iPhone. 

I can steam fine and broadband is working fine so appears an issue with the app. 

145 REPLIES 145

Very Insightful Person
Very Insightful Person

Do you have any specific examples?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Anything I try to download comes up with the same message. 

Hi Prkendrick1


Sorry to hear of the issues regarding content via the TV Go app and recordings, we appreciate you taking the time to raise this via the forums and welcome to the community.


We have help here and here for the TV Go service, some content can't be recorded due to copyright restrictions imposed by the content provider. These are in place to prevent copying and redistribution of copyrighted material.


This may be why you're not able to record movies to watch later, does it happen with other content?



Hi rob


inhave checked the info links you sent and still can’t find a solution. I have tried multiple different movies all of which have the icon to download but when I try all I get is a message to say “unable to download item”.  

I have reinstalled the app, tried on both iPhone and iPad (both on latest version of iOS). And checked my broadband speed and tried on a different broadband network all with no solution. 

Can you confirm a couple of the movies so we can get this checked with the TV Go team to see if it is a fault or a copyright protection process?



It has been every movie I have tried including

top gun maverick

black phone

Operation mincemeat

Death pursuit

they show as able to download but when you click to download it does not work 


Hi @Prkendrick1,

Would you mind providing a screenshot of the error message that appears, please?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!


Very Insightful Person
Very Insightful Person

I'm on the Ultimate Volt package.

Using the TVGO app and searching for The Black Phone it shows that movie "can only be played on your Virgin TV box" -  therefore it can't be downloaded. 

It's the same with Top Gun Maverick and Operation Mincemeat. This will be a restriction based by the broadcaster (Sky)

I was able to download and play Death Pursuit on my Samsung tablet (SM-X205) as that hadn't  got any download restrictions.

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali