Showing results for 
Search instead for 
Did you mean: 

Brand new Stream install. Worked for a whole 10 minutes - now won't start ("Needs more power")

Joining in

Stopped working 10 mins after the installer left.  Now won't start for love nor money.

I've read other people having the same issues.  So I've tried everything that I saw suggested - all to no avail.

- Tried a different micro-USB cable
- Tried a micro-USB cable into a block (instead of using the TVs USB as the installer used)
- Tried the USB cable + block directly into a wall socket (ie no extension cable)
- Replaced the batteries in the remote
- Tried holding down the power button and inserting the USB power.  I was able to update the software, but still getting the same issue.

How is it that this device is happy enough with the power supply to allow the firmware to be updated, but not happy enough to let me watch TV?

Starting to hack me off a bit, this.


Forum Team
Forum Team

Hey @dovert01,

Welcome to the Community Forums and thanks for the post.

Sorry to hear you have been having this issue with your Stream box, I can see you have since called us about this, were they able to help you at all with your query?