Showing results for 
Search instead for 
Did you mean: 

Weird Speed Test Results

Dialled in

I had the 1Gb broadband service installed a few months ago, and other than a couple of outages all has been well. I have a Dream Machine SE which performs a daily speed test, and the results were always above 1Gbps down and 100Mbps up.  

However, about two weeks I had a flashing blue light on the Virgin Hub (5X). The internet was still working so I’m not sure what a flashing blue light indicates on the 5X. Some suggestions where it may have been a firmware update, but that doesn’t seem to have been the case, and the flashing blue light remained until later that day when I restarted the hub.  

Since having the flashing blue light, my daily speed test results have dropped significantly. The upload speed remains at 100+Mbps but my download results have dropped every day:  


If I run a speed test then I usually get better results – 700/800+, but not the 1Gbps+ I was getting prior to the flashing blue light.  

Any ideas? 


Up to speed

the only way to see if your speed is impacted is to check

if thats fine then its a local issue, blue flashing usually means its updating isnt it? not 100% sure though.

Connection: Virgin FTTP Gig2 (XGSPON)

RealSpeed results:


(Download results - Router: 373 - Device: 339)

As for the flashing blue light, a firmware update was my assumption, but it was flashing all day before I finally rebooted it.


Does the faults in your street service : 0800 561 0061 cover XGS-PON connections ?

I've tried the faults service number and nothing reported.

thats definitly not 1gig, although it is on the package, get someone out, it could be a dirty connector.

Connection: Virgin FTTP Gig2 (XGSPON)

Would a dirty connector also affect the upload?

Todays results...

Speed tests performed by the DM SE over the last few days:


and todays RealSpeed test:


It's getting worse every day.

Dialled in

So much for customer support.... after spending over 2 hours trying to speak to someone @ VM about this issue, I finally get put through to the 5X support team, who are then insistent that I have a wifi issue, even after I told them wifi on the hub is turned off and I am performing my speed tests from a machine directly connected to the hub!

I'm livid!

On our wavelength

I guess that we are in the same boat (see, although I did not get or did not notice a flashing blue light on the 5x, after a couple of reboots it is staying solid white. The realspeed tests strongly suggest that it is something that VM have done or are in the process of doing, could be routing issues or unsuccessful attempts at firmware upgrades. I doubt that it is dirty connectors, mine have not been touched for months. 

The flashing blue light may just be coincidence, and after spending hours going round in circles trying to contact VM, I did find a support page that suggests that a flashing blue light indicates that WPS has been triggered, but as I have wifi disabled on the hub it's anyone's guess as to what it meant!

I'm a relatively new install as VM only came live in this area (YO32) in January