cancel
Showing results for 
Search instead for 
Did you mean: 

AWFUL UPLOAD SPEEDS - SR7

danerothery
Joining in

So i my downloads are fine..i have the 1gig package. My Samknows tests show great download and almost equal from router to device. 

but my upload on samknows is showing between 1.0 - MAX 15. 

I keep getting notifications saying there's problems in my area, but I feel at this point I can't just be like "oh okay they're on it.." I'm paying for a service I very clearly don't receive and every time I speak to VM, they just tell me they're aware.. AND?! you're happy to take my money and not give me what I'm paying for? 

my connection was flawless, but since I renewed my contract, I've had nothing but issues and it's been MONTHS! I have a week or two where everything seems great, then it just crumbles again. I've spent hundreds on cabling and switch upgrades, alongside countless hours trying to fix this to find it's ultimately an issue on their end. 

 

please can someone help me with my upload speed checks and get this resolved asap? 

3 REPLIES 3

jbrennand
Very Insightful Person
Very Insightful Person

Try the “free & automated” Service Status number - 0800 561 0061 - which usually gives the most up to date info. and tells you of more local issues and fix estimates, down to street cab/ postcode level.

These are still only "guesstimates" though


--------------------
John
--------------------

I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

I've been checking the website twice daily for about 2 weeks now.. every time I go on it gives me different date / resolution time. By their judgement it should have been fixed about 25 times by now. I'll give the number a try, though. Thanks. 

Hi @danerothery 

Welcome back to the community forums

So sorry to hear of your service concerns. We can see that you've already opened a thread regarding your broadband concerns and have been advised of the area outage affecting you and it's estimated fix time. 

We do ask that members to not open multiple threads regarding the same issue so we can support within one space. This also helps other members how are searching for answers for similar issues find the answers and support within the same thread. 

We've checked again and can see that the outage is still showing as estimated to be resolved on 11/06/24 at 15:10. Should you've any further concerns after this time and the service status is not showing any update or that the issue has been resolved, please do let us know on your original thread and we'll be able to assist you there should you need.

Here to help 🙂
Virgin Media Forums Agent
Carley