Showing results for 
Search instead for 
Did you mean: 

Web safe not working when enabled

Tuning in

Unlike some posts here, I want Child Safe to work.

It's been on since the start. However, it seems to have stopped since a few days ago. I thought it was my phone at first, but now I am testing on the PC, it turns out this is to do with the Child Safe feature not working.
I've tried a router reboot but that has not fixed it.

Despite the options showing as enabled on the Account Settings page, I can still access
- Inappropriate sites that are included as default
- Sites that I added in manually

I am not on any VPN. All my network settings on the PC is automatic, so DNS is default. I changed to Virgin DNS manually too, but that still doesn't work.

Tried from my mobile, with all default settings, doesn't work. Set DNS server to VM's one: doesn't work either.

Please could you check my account and get this sorted.

101 REPLIES 101

Forum Team
Forum Team

Hi @Rangnarok 👋

Welcome to our Community Forums and thanks for your post. 

I am sorry to hear you're experiencing issues with Web Safe. 

I'm going to pop you a PM 📩 now to help further.

Speak soon!

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Forum Team
Forum Team

Thanks for your time via PM @Rangnarok 

Glad to hear WebSafe is now working again for you. 

If you need help with anything else, let me know. 

All the best!

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Mine is now experiencing the same problems, please can you help with this?

Hi @J_Slater, thank you for your post.

We're sorry to hear about the problems you're experiencing 😔

In order to look into this for you further, we'll send you a private message on here. Look out for the envelope in the top right-hand corner. 

If you're on a portable device with a smaller screen, click on the icon in the top right-hand corner and select "messages" from the additional menu options.


Tuning in

Just to close this out, a member of the team reaching out to me, asking to confirm account number, bill etc. But after a few days, Web Safe worked again without anything done in the background.

I still want to know why it happens in the first place, as this is a critical glitch regarding web safety.

Hi @Rangnarok thanks for your post here, we're pleased to hear this is now working for you.

Unfortunately, we don't have any information as to why this happened but rest assured, we are here to support so if you do need any further assistance please don't hesitate to let us know!
Many thanks


Hi Ayisha,

I am experiencing the same issue. Child safe is not turning on. Please can you help with this?



Hey SanB12, thank you for reaching out and I am sorry to hear this.

I will send you a PM now to get this looked into. Cheers 

Matt - Forum Team

New around here?

Joining in

Hi, my child safe is not working and I want this to.  I have small children at home and need this to be working correctly as selected. 

We have tried deselecting and reselect but has not worked.  

Please can you correct this urgently.