Showing results for 
Search instead for 
Did you mean: 

printer not connecting wireless after HUB 5 put in by virgin

Joining in

My printer which was working perfectly with old router will not connect wireless to HUB 5 even with tech from gadget rescue (paid by me via Virgin) stepped in.  I see others have had this issue.  Please help.  I am not very techi




Alessandro Volta

Hub don't like printer you need to get your own router with 1Gb ports and put hub in modem mode



Hub 5 with Wi-Fi 6 on the 2.4Ghz band has provided compatibility  issues with many devices.

Which make & model of printer is involved ?

Do you have the printer's installation manual and options to hand ?

Very Insightful Person
Very Insightful Person

Try this first....

Log into the Hub settings and navigate to the wireless page an click the box to switch off the 5GHz wifi signal and also turn "intelligent wifi" off.   Save and exit then reboot the Hub.  It should now connect to the 2.4 band.  If it does then go back in and re-enable the 5GHz signal (leave intelligent wifi off)

If that fails to sort it then do this more permanent fix...


If you haven't done this already - try it first - it helps sort some Hub3/4/5 wifi issues for some devices.
Go into the Hub’s settings. Type in  into your web browser’s url box and login with settings password on the Hub's base sticker (or your own if you changed it). Then in Advanced>wireless signal >smart wifi - tick the disable “channel optimisation” box or the“Smart Wifi” box and save settings.  May be different pathways and wording on the 3 Hub types This (message 2) is for a Hub3…

Then, go to advanced>wireless signal>security, rename the 2.4 & 5 GHz network ssid's.  Just type over to change 'em to whatever you like and something that will differentiate them (e.g - Billybob_2 & Billybob_5) Try to avoid spaces and periods in the SSID names as they can cause issues with certain devices. Use the same password for simplicity,  Then, apply settings and restart the Hub.  Your 2 wifi networks will now be clearly separated - and you can then select the network you want each device to connect to… individually from the "available networks" list on each of your devices. 

Note all your wifi devices will need re-connecting to the new SSID's and passwords.
All things being equal, 5 GHz is always better/faster and subject to less congestion/interference (and is better for iDevice speeds than the 2.4 one - although the 2.4 one has the better "range" and will be needed when the 5 GHz drops out of range and some older/cheaper/dumber or “specialised” devices can only use this one. 

You should also use a wifi analyser App (or Airport Utility on iOS) to check which 2.4 channels are being heavily used around you and move yours to one of numbers 1,6,11 that is least so, but it wont help if there is other interference.
See if these changes help - you will lose any “seamless roaming” benefits but it may not matter and you can always change the settings back by doing a " pinhole factory reset " if you prefer the way it was - or it doesn’t help.



I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Forum Team
Forum Team

Thanks for reaching out to us @Flower420, and a very warm welcome to our Community Forums!

Sorry to hear of the difficulty connecting the printer to your newly issued Hub 5.

Do please let us know if any of the suggestions provided by your fellow posters have helped resolve this issue for you, or if further assistance is required.