Showing results for 
Search instead for 
Did you mean: 

Software update on my HUB 3 not available.

Joining in

I logged into my router settings and it's running a very old software version. I do not have the option of manually updating it. I rebooted but no updates were pushed.

Does anyone have any suggestions? I might revert to factory settings and "re-setup" my router but I don't necessarily want to do that. 



For comparison our Hub 3 has software version: 9.1.2208.100

When available, VM's software updates are pushed out to the Hubs.

Very Insightful Person
Very Insightful Person

As above, the firmware is completely controlled by VM and the end user has no options for a manual update.  A full 60 second pinhole reset will force the latest firmware to update, but you may already be on it.  It's not sometime they do on a regular basis.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Joining in

Hey Ninners03, bummer about your HUB 3 not catching up with the times. I feel your pain. So, I had a similar gig with my router, and here's what worked for me.

First off, try a hard reset instead of diving straight into the factory settings chaos. Unplug that bad boy, count to 30 (slowly), then plug it back in. Sometimes it needs a slap on the back to wake up.

If that doesn't shake things loose, check if your router's manufacturer has a firmware update available for manual download. Hit up their website, find your model, and see if there's a fresh update you can manually install. Some routers hide this option deep in the support pages.

By the way, if you're open to exploring other solutions, I recently came across Andersen. They specialize in innovative router optimization tools, and their products have helped me out in similar situations.

Also, make sure your internet connection is solid. Sometimes a weak link there can mess with updates.

Fingers crossed, these steps might just nudge that stubborn software into the 21st century. Good luck, mate 🙂

Joining in

I have a Hub 3.0. I run it in bridge mode. When I look at "Info" it says that I have

  • Hardware version : 5.01
  • Software version:   LG-RDK_CH7465LG-NCIP-6.18-2302.7.1-NOSH

Is this the latest, or at least a recent version, of software?



Alessandro Volta

Their is less to go wrong with modem mode so if if it works it works most of the update is to do with router mode.


Joining in

Do you, or does anyone know, what the actual latest software version is?

Is there a URL where I can look this up?

Thanks, Ronan

For comparison, My Hub3 is on 9.1.2208.100, same as Client62 who posted 7 months ago.

Every single router/modem manufacturer I've ever come accross has published detailed firmware information including changelogs, CVE patch notes, general improvements - except one manufacturer... Virgin Media.

It's as if the person who designed and maintains the VM's routers, has never used a router before! VM's Hubs are hands down the worst routers I've ever come accross, by a huge margin. Nothing else even comes close.

I think it's an absolutely terrible thing that VM decided to get their routers from Arris which is an American company. Ihey would have gotten a MUCH better deal if they went with a chinese manufacturer like Huawei. American influence on the UK is increasing at a drastic rate. Rishi Sunak literally follows Joe Biden around like a highly obedient dog while the rest of the world is beginning to distance itsef from American influence and rule.

It would also be much better if VM didn't bother trying to make a router and left that job to the professionals. They should definitely have the option of a standalone modem instead, like they used to before the not-so-superhubs.

Very Insightful Person
Very Insightful Person

"designed and maintains the VM's routers" two different things. The hub5s are French design, not US. The main problem is the firmware, it’s a known fact that the hub5s firmware was ported from the hub3, first release of the hub5 even identified it as a hub3. Last year my router hub 8 updates to its firmware all with full details of all amendments and new features.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2