cancel
Showing results for 
Search instead for 
Did you mean: 

Packet loss, high ping, poor connectivity

Mockingbird_DX
Joining in

[MOD EDIT: Personal and private information has been removed from this post.]

Hub 3.0

Issues are intermittent, started a few days ago. Intermittent - at times feels like everything is fine, at times I literally have no connection as total loss is over 90%.

Poor connectivity, high packet loss over wifi on the modem. Connecting over cable gets rid of modem packet loss but there is also loss between the modem and other virgin media (see mtr screens - one made over wifi about 1.5m away from the hub, the second one was made with a cable connection) - also cable connection is not a viable solution here for me.

In day-to-day this means some http web pages take anywhere from 5 to 30 seconds to load, video calls are horrible quality, online gaming is impossible.

Ran a connection check with virgin media check services - it told me to hard-reset the modem. Didn't make a difference.

See also attached some PING results made from the hub itself to google.com and google dns @ 8.8.8.8

As far as I understand there are two issues:
1. Packet loss over wifi to modem
2. Packet loss in the virgin network in the area

Tried starting chat with support, chat is't working (lol)

 Wifi connectionWifi connectionCable connectionCable connection

mtr wifi to googlecommtr wifi to googlecom

hub ping to 8.8.8.8hub ping to 8.8.8.8

10 REPLIES 10

Client62
Hero

Google Public DNS is expected to respond to NSLOOKUP there is no assurance it will repeatedly respond to PING.
Perform 50 :  nslookup hp.com 8.8.8.8    see how many lookups fail doing the intended task.


Use the link below to test for Packet loss at the VM Hub and at your devices...

https://www.samknows.com/realspeed/

Once the test begins click on: Run full test to see Packet Loss, Latency, Jitter, Upload speed.

Mockingbird_DX
Joining in

Hi

I also got ahold of a support agent over the phone about 3 hours ago and they walked me through resetting the hub to factory settings once again, which helped for an hour or two, but here I am again.

To be fair I've ran several thousand of nslookup hp.com 8.8.8.8 - didn't fail even once.
I've also ran pings to various web hosts, for example google.com (this is the worst one, others like youtube, facebook, etc were better with loss of 0.2% to 3.4% and haha yeah hp.com is all good):
--- google.com ping statistics ---
100 packets transmitted, 86 packets received, 14.0% packet loss
round-trip min/avg/max/stddev = 84.143/497.887/2264.695/587.531 ms


Various web-based tests show constantly inconsistent results, here is the samknows test you mentioned is below (this is done via WiFi - in the same room, about 2 meters away from the hub with nothing physically in between the hub and the laptop) and no, it doesn't display the 'detailed' results at times at all, but when it does - the packet loss is admittedly zero. It is heavily inconsistent though - the "device" download speed is wildly different in every run - from 30 to 280.

I also did the cloudflare test (see below) which displays wild variety in speeds and packet loss again. And some other (likely useless) tests. They are all over the place.

I have three laptops in the household, tried them all.

I understand you guys can't guarantee wifi coverage throughout the house - that's perfectly understandable, but I'm right next to the hub.
And what worries me is the inconsistency - sometimes it's great and snappy, sometimes it takes 25 seconds for youtube.com to start loading (yes, I timed that). And I worry if I shell out on a proper wifi router and have your hub work as modem only - will it really be better?

Screenshot 2023-12-05 at 17.51.30.png

Screenshot 2023-12-05 at 17.57.11.png

Screenshot 2023-12-05 at 18.02.55.pngScreenshot 2023-12-05 at 18.03.03.png

Client62
Hero

We have VM Hub 3 in Router mode + two Wireless Access Points to extend Wi-Fi coverage  in a family home.  We don't have any issues with Facebook or YouTube even with uBlock Origin making it an advert free experience. In the VM online account we have Child Safe : Disabled and Virus Safe : Enabled.


--- google.com ping statistics ---

100 packets transmitted, 86 packets received, 14.0% packet loss
round-trip min/avg/max/stddev = 84.143/497.887/2264.695/587.531 ms

The above stats from the Hub 3 Ping screen are nonsense, look at what happens, the first batch of Hub 3 pings have reasonable response times, but after 20 or 30 pings suddenly the reported ping time jumps by a factor of 1000x to 15,000x reality.  So we go from pings on our LAN at < 1ms to over 10,000ms which is 10 seconds.  Clearly the Hub Ping is not waiting 10 to 15s for a response from a Cisco ATA device that is directly network cable connected. 

For Ping tests, a Command prompt window will provide a reliable batch test
E.g:   ping -n 100 google.com        

SamKnows Realspeed is supposed to be consent at the VM Hub, and is supposed to show the varying performance of your Wi-Fi device as you move about the home. This you appear to be seeing.


Client62
Hero

Regarding the Hub 3 Wi-Fi we have made the following changes to our Hub 3 Wi-Fi
settings the goal of which are :

1) To prevent Hub 3 Wi-Fi dropouts lasting seconds caused by Smart -WiFi or Auto Channels
2) To ensure the Hub 3 stays on specific channels so as not to clash with our two Wi-Fi APs
3) To disable transmission in Wi-Fi modes "a/b/g" only required for kit built between 1997 to 2006.
4) To match the 5GHz Channel width to the abilities of our devices.


Client62_0-1689525728997.png

Client62
Hero

Given the lumpy performance it might be worth a look at Hub Signal Level Checks

Via http://192.168.0.1/ connect to the Hub in Router mode, do not login in, scroll down to "Check router status"     Use http://192.168.100.1/ for a Hub in Modem mode

Using the Hub's "Check router status" tabs check the Downstream and Upstream power levels are in spec.

( If already logged in to the Hub menu, the same info is available at : Advanced settings >>> Tools >>> Network status )

Downstream Power Levels of -7 to +7 dBmV are preferred, +10dBmV is the max acceptable, with a SNR of 33dB or higher across all DOCSIS 3.0 channels. Rising error counts across many channels is a current service noise fault.

Upstream
Power Levels of 35 to 49 dBmV are preferred, with QAM 64 Modulation mode across all four to six DOCSIS 3.0 channels.  Seeing QAM 32/16/QPSK is a current service noise fault.  Seeing less than four DOCSIS 3.0 channels is usually a signal level fault.

Thank you for reaching out and I am sorry to hear this Mockingbird_DX, we understand this is frustrating.

The speeds you get at home will, of course, depend on a variety of factors, it depends on your package, what and how many devices you have, how they are connected amongst other things.
We do have a download speed guarantee though - this will show the minimum speed we would expect for all our packages - you can take a look at that here: 

There are so many things that can influence a WiFi connection some of which include but are not limited to, a fish tank being in the same room, walls being built with concrete instead of brick, it could even be that your next door neighbours router is interfering with yours. Due to this, we are only able to offer limited help. Please have a look here: https://virg.in/wifisos

The Hub's location could also be causing the coverage problem so we do need to check the positioning of it. Can you please ensure the following:

> Out in the open

> Next to the TV not behind it

> Away from large bodies of water (e.g. fish tanks)

> Away from baby monitors and cordless phones

> Away from microwaves

Think of the Hub as a radio, and WiFi as the sound - the further away you are from the radio, or the more obstacles that are in the way (walls, electronic devices etc.), the quieter the radio & the poorer the WiFi.

 

If that doesn't help, if you have the Hub 3, you can download our Connect App which will allow you to scan areas of your home and will offer help. You can view more information on that here:Cheers 

Matt - Forum Team


New around here?

Mockingbird_DX
Joining in

Hi Matt

Thanks for the comment, but it's definitely not about Wifi. What I've done is I've switched the Hub into modem-only mode and I've invested in a stronger WiFi6 3-piece mesh system and also into a couple of cables that go into the hub to be able to use a wired connection if wifi failed. Neither option made it better.

Issues continue - they're not constant, most issues are around 16:00-19:00 on weekdays - to the point where it's literally impossible to use the internet regardless if it's wifi or RJ-45 wired connections.

Virgin service check page always recommends resetting the Hub. Support line agent also did that and claims they don't see any issues. Note that at most other times the situation is good. And the problems only started about 10-12 days ago, I didn't have any problems until then - service was great, I didn't need any cable or wifi extenders.

What monitoring can I set up or which tools can I use to gather more reliable and detailed information about the issue?

I'm honestly at the point where I'm close to cancelling the service, I'm working from home and my work requires a lot of communication and I'm forced to use my cell internet as videocalls are falling apart and failing even over the cable connection.

Mockingbird_DX
Joining in

Downstream bonded channels

Channel Frequency (Hz) Power (dBmV) SNR (dB) Modulation Channel ID

13310000009.440256 qam25
22030000009.340256 qam9
32110000009.140256 qam10
42190000009.440256 qam11
52270000009.443256 qam12
6235000000940256 qam13
72430000009.143256 qam14
8251000000940256 qam15
9259000000940256 qam16
10267000000940256 qam17
112750000009.340256 qam18
122830000009.140256 qam19
13291000000940256 qam20
142990000009.540256 qam21
153070000009.440256 qam22
163150000009.440256 qam23
17323000000943256 qam24
183390000009.840256 qam26
193470000009.140256 qam27
20355000000940256 qam28
213630000009.340256 qam29
223710000009.340256 qam30
233790000009.140256 qam31
24387000000940256 qam32



Downstream bonded channels

Channel Locked Status RxMER (dB) Pre RS Errors Post RS Errors

1Locked40.9110
2Locked40.9250
3Locked40.970
4Locked40.970
5Locked43.3120
6Locked40.980
7Locked43.3120
8Locked40.950
9Locked40.9120
10Locked40.3120
11Locked40.9230
12Locked40.980
13Locked40.990
14Locked40.9250
15Locked40.9120
16Locked40.9140
17Locked43.3120
18Locked40.9190
19Locked40.9170
20Locked40.9400
21Locked40.3240
22Locked40.9320
23Locked40.9210
24Locked40.9180

Upstream bonded channels

Channel Frequency (Hz) Power (dBmV) Symbol Rate (ksps) Modulation Channel ID

14960000042.8512064 qam1
22360000041.3512064 qam5
33010000041.3512064 qam4
43660000042.8512064 qam3
54310001942.8512064 qam2

 

Upstream bonded channels

Channel Channel Type T1 Timeouts T2 Timeouts T3 Timeouts T4 Timeouts

1ATDMA0000
2ATDMA0000
3ATDMA0020
4ATDMA0000
5ATDMA0000

Thanks for providing that information @Mockingbird_DX 

I have checked the systems at my side and cannot see any issues in the area that might be causing this. 
Your power levels are on the higher end of being in specifications so I wouldn't imagine that this was the main cause of the issue. 

I think might be best with having an engineer come and investigate further. Please join me on private message so I can locate your account and pass account security. You can see your private messages at the top of the page, in the envelope icon or if you're using a smaller device, you can see your private messages by clicking on the Virgin Media logo at the top right and select 'Messages' from the drop down. 

Here to help 🙂
Virgin Media Forums Agent
Carley