Showing results for 
Search instead for 
Did you mean: 

Hub3 Modem Mode Not Working

Tuning in

Hello - we have an issue where our Hub3 will not work in modem mode. It works fine in router mode. 

The issue is especially weird in that we actually get a public IP in the modem mode and we can ping the Virgin gateway (the next hop beyond our modem, what I can assume is the CMTS) - however we can't ping anything beyond that. This is the behavior with two routers and a laptop connected directly, so it doesn't seem to be a router issues.  

All signal levels are fine, no unrecoverable errors on any channels. We have tried a full reset of the Hub 3 times now and each time when switching to Modem mode it stops working - although ping to the Virgin gateway works. The LED when in modem mode seems to be red rather than magenta but it's hard to say. 

Has anyone found a fix for this? It seems like we are being blocked by Virgin somehow. 


Very Insightful Person
Very Insightful Person

You must follow the correct sequence.

How to put a VM hub into modem mode:

1) Access your hub on, sign on and put it into modem mode. On the Hub3 the bottom LED will change to magenta, on a Hub4 the LED band will be green, on a Hub5 the LED will be green. Best done from a wired connection.

2) Turn off the hub and disconnect any Ethernet cables

3) Fully initialise your own router or mesh master unit and make sure the WAN port is set to DHCP (for some routers or mesh this may have to be done in router mode before entering modem mode)

4) Connect your router or mesh master unit to the VM hub with an Ethernet cable, Cat5e or Cat6, any higher specification is a waste of money. On a Hub5 use port 4.

5) Turn on the VM hub.

6) You should now be able to access the internet and the hub will now be on

Note1: this only needs doing once for each new router or when VM changes your WAN IP address.

Note2: If you have a Hub4 and your own router is NOT then it’s possible that you can still access the VM hub on

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

Alessandro Volta

by WAN IP its not

if it is a WAN IP then VM have forgot to remove a non working subnet from their DHCP server which you have to wait for them to remove it or use another MAC if you connect a PC to the hub in modem mode you get a new IP then copy that MAC to your router.


Hello - yes I am succesfully in modem mod and have a WAN IP as you say. It seems like a non-working subnet.

I've switched the MAC on the router and tried a computer as well. Both router and computer get an 82.x.x.x IP on Virgin's public IP space in London with a /23 subnet. I can ping the gateway address (the first IP in the subnet which is not my IP - another device on Virgin's network) but I can't reach anything beyond the gateway. So I think this must be a routing problem. I've tried switching the MAC, got a second IP and tried a computer with yet another MAC and got a 3rd IP. For some reason, none of the IPs seem to route beyond the local gateway. 

Is there anyone who has also experienced this? @legacy1 I am curious to hear more about this subnet issue. Do they randomly stop working need to switch? It's odd I would get 3 in a row. 

Just to mention, I assume if I am getting a public IP then I've followed the modem mode sequence correctly. Usually it will not assign DHCP to devices with a different MAC until rebooting the modem or waiting for the timeout. 

Alessandro Volta

Odd...with all the WAN IP's you have tried...

with a PC to the hub in modem mode change the MAC to be like the MAC on the hub but with the last digits 4 HEX digits away from it.


Oh, that's a good idea - then maybe I'll get the same subnet as the modem - ok I will try tonight. 

Alessandro Volta

No you will not get the IP router mode gets as the MAC (up hex up from the MAC listed on the hub) used is part of the bridge so it causes traffic not to work which was the case with SH1 so all models are build likely like this. But my way of thinking is maybe someone listed a allowed MAC list range so by using a MAC in this range it might work? Or VM are making modem mode harder to use  by some method that stops traffic going beyond one hop.