Showing results for 
Search instead for 
Did you mean: 

Unable to register - getting errors

Joining in

I'm also hitting this problem when attempting to register for a Virgin Media account.

More details:
- Occurs at the address
- Under the hood, this appears to be making a POST request to, which fails with the error `There was an unexpected error`
- The UI only displays the error message `Sorry, there was a problem registering that password. Please choose a different one.`
- The provided password meets the shown requirements, and is set to the same value in both fields
- Clearing cache or using a different browser does not appear to help. From the API response, this appears to be a server error on Virgin's end.

Would appreciate a DM from Virgin Media staff about this if possible.


Forum Team (Retired)
Forum Team (Retired)

Hey domodomegg, thank you for joining our help forums and for your first post here. 

Welcome to the VM community, great to have you on board! 🙂

Sorry to hear of this issue with the password creation for your online account currently, we'd love to help.

Please, have a read at the below requirements for creating a new password.

New password must:

•  Be between 8-64 characters.
•  Must start with a letter.
•  Contain at least one uppercase and one lowercase letter.

•  Contain at least one number.

•  Special characters are allowed but not required (e.g. ! # % & @).
•  Cannot contain easy to guess words, usernames, or previously used passwords.

Let us know if by meeting these requirements you're able to create a password for MyVM successfully. 

Not to worry if not, just tell us what error you get or what goes wrong during the process and we'll be happy to assist further.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Thanks for your response. I checked the password meets the requirements and I am still unable to register for MyVM.

I called up customer services today, who first guided me through the process again and we got stuck at the same point. They then tried to create the account from their side with a password they chose and also were unable to. The agent esclated to their manager who also was unable to create the account. I was told it had been referred to an internal technical team as a fault in the MyVM system.

Just joined

Hey domdomegg, sorry to hear about your registration struggles with Virgin Media. Tech hiccups can indeed be a headache when you're just trying to sign up for something. I've faced a similar issue before, not specifically with Virgin, but errors during registration are pretty universal.

Now, regarding the POST request error you spotted, it seems like a glitch on their server end. First off, have you tried reaching out to their customer support? They might have a quick fix or at least shed some light on the situation. In the past, I've found contacting support surprisingly helpful for these kinds of website quirks.

If that doesn't do the trick, maybe shoot them a tweet or hit up their social media. Sometimes, companies respond faster to public nudges. And hey, you're not alone in this – others might be facing the same issue. Sharing your experience here could also help someone who's scratching their head over the same problem.

By the way, if you're tech-savvy or have someone who is, exploring API-Integration und API-Entwicklung might be worth considering. Sometimes, understanding the backend processes can provide additional insights or even alternative solutions. Good luck, and I hope you get it sorted soon.