Showing results for 
Search instead for 
Did you mean: 

I can't register my account

Joining in

When I try and register my account, I get emailed a link but upon clicking it, it tells me the link has expired. From the same web page where it tells me my link is expired, I can request a new link, but it's the same experience in a loop.

I just tried again, and I didn't receive a verification link via email at all. I also tried "forgot your password" but also did not receive an email to generate a new password.

I can see lots of other people on your forums complain about an identical experience. You DM the person to resolve and get them set up. Can someone do this for me so I can complete the sign up process?

It might be worth investigating the root cause and sharing the feedback with the team who own the sign-up process to create a better customer experience.


Forum Team
Forum Team

Hi Adamcook807 👋🏼.

Thank you for posting, welcoming you with big virtual arms onto our community forum 🤗.

Sorry to see you are having issues with registering your account and the link isn't working ☹.

Please make sure you are using the same email you used to register with us.  

Please can you confirm you are having the same issue whilst trying to do it through our app?

I can further investigate this 🧐 and see what we can do, I will have to private message you. 

Please watch out for the envelope ✉.  

Ari - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Joining in

Yes, I'm using the same email address I signed up with and it's the same experience via the app.