Showing results for 
Search instead for 
Did you mean: 

subsidiary email account needs password

Tuning in

Hi - I have a primary account and five subsidiary accounts.  One of the subsidiary accounts now says "password required"  If I use the primary account password it still doesn't access the subsidiary accounts.  All the other accounts are working normally.

I've tried removing the subsidiary account from the device and then re-installing it using the primary account password but still no success.


Any thoughts?



Very Insightful Person
Very Insightful Person

Each email address now has its own My VM account
Secondary accounts changes now have to be made via the My Virgin Media account for the secondary email.

Sign into the account here: using the email address concerned and the current password. Once logged in click on Account Settings then Account details. You should now see the options to change password etc.
If that isn't available try
If no security answers have been set for the email address concerned then you will need to call in for support and select technical issues> email


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media, I'm a VM customer. There are no guarantees that my advice will work. Please read the FAQs
Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks