Showing results for 
Search instead for 
Did you mean: 

Hub 5 fails on port 4 when latest firmware upgrade happens - Virgin have their head in the sand (again).

Tuning in

On Feb/26/27 overnight my Hub 5 received an upgrade and the next day port 4 (2.5 gbs) refused to communicate with the switch connected to it. Wireshark indicate (among other things) that all the NIC's behind it could not locate There are also problems with EEE capable (energy efficient ethernet) devices. Note the problem only seems to affect Gig1 customers; switching off EEE generally helps, but unmanaged switches do not allow you to do this. I plugged my 10Gbs networks cards into port four to see what happened; the Intel X540 worked, but only at 920 Mbs, while the Marvell Aqtion refused to do anything. I suspect many Gig1 customers are unaware of the problem if the haven't run a speed test, but my switch manufacturer has had numerous reports of "failing QSW 2104-2T units, all from Virgin customers.

However, when you plug into ports 1,2 or 3 (I gbs) the entire network ( 2 huge desktops, 1 medium sized one, three laptops and 5 phones, worked as expected. This reminds me of the problems the industry had back when we moved from 10/100Mbs equipment to 100/1000 Mbs gear; may pieces of kit similar refused to up their speed when connected to ISP routers. But as a gig 1 customer used to 1160 mbs on every speed test I run  each week, dropping to 920 mbs was wholly unacceptable. After a week Virgin replaced the router from stores, and of course that same night the firmware was updated again, restoring the original problem, a great piece of customer support. Since when they have prevaricated, lied, cut me off while "transferring" me and so on. A formal complaint via the website was never replied to (swallowed up by a Hub 5, no doubt) and so I decided to restore things myself.

It's actually quite simple, just pricey, especially when you have a home network that runs at 2.5 GBs and 10 gbs. The network has two 10Gbs network cards, two 2.5 gbs USB LAN adapters and two more 1 Gbs USB LAN adapters; the phones generally connect to Wi-fi at 433 mbs. First thing is to remove the faulty firmware by putting the Hub 5 into modem mode. This is fine, now all you have is a dumb cable modem which only uses port 4 and no longer caps your gig1 feed at 920-940 mbs.. So now you need a router (I bought a TP Link ER707-M2) which has  two 2.5 gbs ports, one to connect to the Hub 5 and the other to the switch, which is an unmanaged  QNAP QSW 2104-T. That caters for 2x10Gbs, and 4x2.5Gbs, which  leaves me to deal with Wi-fi, because that disappears when you switch a Hub 5 into modem mode; all of your other Hub 5 functions also disappear, so you need the second router just to establish a physical firewall, and all the DHCP functions. 

Because the TP Link router has six 1Gbs ports, I decided to go for a Ethernet to Wi-fi access point (a BrosTrend AX3000, which is Wi-Fi 6 with a 1 Gbs LAN port). This also has the advantage that I can place all the Windows based machines on Ethernet, all the Android ones on Wi-Fi,. And it works well; the house is cabled with CAT 8 throughout and we have at last banished all 2.4 Ghz traffic on the wireless network. The system still runs NordVPN on all Windows machines, Comodo protects network access on both Ethernet and Wi-Fi, and not a single problem has emerged. Only router and access point have had to be configured, and the TP-Link offers far more functionality than the hopeless Hub 5. In fact I have a much nicer, safer and coherent network than before.

A word of caution. When you set the Hub 5 to modem mode, wait for a continuous green light on the Hub 5  (took about 4 mins for me, but will take up to 8-10 mins on older machines), then power the system down and also the Hub 5, most important. Next configure the new router to deal  with basic setup parameters BEFORE you reconnect the Hub 5 to the new router and power it up. It seems (again according to wireshark) that if you don't, the WAN IP address gets lost! But the second time through the process  all worked well. 

It's cost me around £250, money that I've had to spend as a direct result of Virgins inefficiency and incompetence. I also complained to the ASA about Virgin's advertising 1130 Mbs average speeds for Gig1, and I'm hoping they'll send someone round to have a look at it; they were not at all impressed by a 20+% reduction of advertised speeds. While I fully accept that they will have periods when traffic volumes are high and speeds drop, the fact is the firmware upgrade means the equipment they have installed can NEVER, EVER, offer me that advertised speed unless they take immediate remedial action, and it is quite clear they have no intention of even acknowledging the fault, let alone rectifying faulty firmware. My solicitor says I would win a breach of contract case hands down, and as nex fibre have started work locally that may well happen, because I have lost all respect for Virgin media, and I've used them since they started..

Lastly, energy efficient ethernet is a joke. A study in the USA recently concluded the entire USA would save $450 million dollars over three years, or approximately $0.19 for every piece of eligible equipment. And it's slower while increasing traffic on networks; if you have to send a signal to power the other end down and then wake it up again you generate interrupts and o/s calls at both ends of a connection. Instead of trying to be Green, Virgin have shown themselves to be Green, by not testing firmware upgrades properly.


Accepted Solutions

Very Insightful Person
Very Insightful Person

Long thread about this here.  Some users have solved with a managed switch.  Hub 5 Firmware Upgrade - Virgin Media Community - 5480079


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

See where this Helpful Answer was posted


Joining in

It's incredible how they do this and then simply ignore the outcome.

They probably have a threshold of tolerance, so unless it generates over X thousand support tickets then <this is fine> meme.

To top it off, when you do try to get it resolved, they then stick people on their support channels who don't even know the difference between 2.4GHz Wireless and 2.5Gbps Wired connections... and are not even trained in their main product. The very product you just answered 20 questions to get through to someone about.


Give. Me. Strength...


Oh, that's quite responsive compared to some that they employ; I htink they jus copy things off crib sheets! And they deliberately lied to you; I and several friends have, like you, complained endlessly, every single day in my case for two weeks before I gave up and got on with revamping my network. I'm seeing my solicitor again today, and I'm expecting him to advise me to proceed, in which case I'll sue in small claims, which they almost certainly won't contest (why ask for bad publicity?), after which I'll set up a website and launch a class action suit; I have a no win - no fee guy who's very interested and a nephew who's a decent barrister who say that he'll take it on. My best estimate is that there are around 10-20k people affected, and most won't even realise it, YET. They'll have to defend that, and I have a few friendly journalists here in Chelsea, TV and press. All they can argue is the extent of damage, which is why I'm trying to get ASA on board; if they proceed the publicity will hurt them..

To be fair, I gather upgrades are controlled by Sagem, but who told them to do it? Sagem are their agents, and so Virgin are 100% responsible; they may have cause for an action against Sagem, but that is their problem. I think they are still installing that upgrade too. 

I recently had a problem with Comodo, NordVPN and Windows not playing nicely on my LAN, dropping machines out at random. Microsoft just said "not our problem, use Defender", Comodo had no other instances, but asked to be kept informed after having verified ALL of my settings (they are very helpful), and NordVPN were fabulous. It took two days, but in the end it was solved by going down an OSI ethernet layer and using adapter addresses within Windows networking, rather than symbolic names. Strange thing is, when you do that, File explorer then lists all shares for every adapter that you  enter. Set each share to "everyone" and "full control" and it doesn't even bother with Windows Credentials, you've just established a huge multiple machine file manager! It even works in my preferred file manager, XYplorer, which is a nice piece of work. Throughout, everyone I dealt with in Panama wrote fluent English and was capable of thinking outside of the box, while every time you run diagnostics it transfers them to Panama and you just send the ticket number to the person on their live chat. More to the point, if they refer you to a colleague it takes 10-15 seconds with no verification and so I went through four or of them five and not one seem to mind; the customer obviously came first. I would not go elsewhere for a VPN. More to the point, when I complained about  the roll over price hike they did not haggle, they just re-instated the same price. Their servers never go down, and using a server in Amsterdam from London the latency is 20 Ms and speeds on Gig1 are 113095-100 Mbs, against as against 10 ms and 1160/106 running to OVH at Erith, Kent. I use Nperf stand alone for all my speed tests, and it's a really nice piece of software. 

Anyway, have fun and hope you find a solution, which eventually will be a reversion to the previous firmware, always assuming the Hub 5 can actually do that! Have fun.


Very Insightful Person
Very Insightful Person

Long thread about this here.  Some users have solved with a managed switch.  Hub 5 Firmware Upgrade - Virgin Media Community - 5480079


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Alessandro Volta

And VM motto is "We like it fast!"