Showing results for 
Search instead for 
Did you mean: 

Virgin tv go not working

Joining in

If someone can help that would be great. I have been in contact with support and they cant help and I have to authenticate everytime which take 3 hours just to start and then nothing gets done. Upgraded my package to allow tv. Now I cant watch any. They said all set from the 22nd of Jan. I am now starting to question if any of it is worth it. Made the updgrade on the 15th of Jan. We now sitting on the 27th of Jan. And no one can fix the issue and I have seen so many posts on here with the same issue. And no solution. The Virgin tv go app wont allow me to sign in and when I try register it says you have an account with us already. I then try that and it takes me to my virgin media account. If I try sign in it says sorry this service is currently not available try again in a few moments. My skysports App works perfectly fine and I can log in and watch that all fine. But try watch virgin tv. That is impossible. Its getting to a point where I want to cancel all virgin media services and just can everything. Again I have tried to contact support with the same issue and no result. Plus if I go into my account and check the TV package it shows I have it. Then it sometimes says that I dont have a tv service with Virgin. If someone could actually fix this, I would appreciate any support. Otherwise I am will be cancelling as I am paying for something that I can't use. 


Forum Team
Forum Team

Thanks for reaching out to us @Clachr, and a very warm welcome to our Community Forums!

I'm sorry to hear of the issues you've been experiencing with the TV Go services and potentially with the self-care account also.

I'd be happy to take a closer look into this one for you, check out the envelope in the top right hand corner for a private message from me.



Forum Team
Forum Team

Thanks for coming back to me via private message @Clachr

Sorry I'm not able to assist you further on this one.

Do feel free to come back to us if you have any further question or queries for us to look into in regards to your subscription.




I am in the same boat as clachr. We updated our package a week ago and since then the TV go app has not worked on any device we have. I have tried all suggestions but nothing works. I called virgin and they said they are aware of issue and trying to fix and would be in touch. I have heard nothing. Please someone tell us how we can fix this. Otherwise like clachr I will be cancelling my contract. 

I have attached a screen shot of the message we get on every device. 

Help someone please..... 


Hi @Marseybear 

Welcome to the community forums 

Sorry to hear you're having the same issues 

Can you advise what devices you're trying to access TVGO? 
Does any of your devices allow access and streaming on the website at all or do you get the same error? 

Here to help 🙂
Virgin Media Forums Agent


Yes getting the same message on the website. 

I have tried to access on Samsung tablet, huawei tablet,  Sony phone, iPhone and get exactly the same message.

I have tried all the fixes suggested on the forum and no joy. 

It worked fine before we upgraded purr package.  

Many thanks 


Hi Marseybear,

Thank you for the update, really sorry to hear this is the same on all devices, you advised this worked before you upgraded, what changes were made?




We upgraded to mega tv and included tnt sports. We also upgraded our broadband to mega volt.


Many thanks, 

Thanks for the update on the forums @Marseybear. 😇

I'm glad you were able to find a new contract.
Reach out to us for any other queries and we'll assist where we can.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


My response about my package was in response to Paul's message asking about what changes had been made. 

Ever since we changed our contract Virgin tv go has not worked on any device we have. That is why I joined the forum to see if there was an answer. I have spoke to virgin with no joy this was my last resort. We have tried all fixes, reboot, password change everything. It is just not right and from looking at this forum it is just not me. 

Does anyone have any suggestions???

Many thanks