Showing results for 
Search instead for 
Did you mean: 

Virgin TV Go not working on iPad

Joining in

When I log in to the app on my iPad it just says “Oops - the service isn’t available at the moment. Try again in a few minutes”. Happened for days. iPad software and app up to date, app works on my phone. Any help? Is there any iOS too old to work?


Forum Team
Forum Team

Hi sm92 thanks for posting and welcome back to our community.

Sorry to hear that TV Go is not working on your iPad.  And for any inconvenience this may be causing.  And sorry if none of the helpful tips on here, are not helping your specific issue.  When you say that the app is working as it should, on your phone handset, is that also an apple device?  



Yes, it’s an iPhone and works fine. I did have to rename my iPhone recently and save as a device after using it for years. But I can’t even get to that step on my iPad as I get that error message

Hi @sm92

Thank you for expanding. If you haven't done so already, can you try removing and then re-downloading the app and giving it another go?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

Tuning in

I have the same issue on my iPad. I have cleared all cookies in browser and removed the app then reinstalled. Same issue when logging in through website. Am able to log in through phone which is android.

Hi Psychotic,

Thank you for your post and welcome to the community. 

I'm very sorry to hear about the issue with accessing Tv Go. 

Can you confirm if you have tried to access this via different web browsers? If so, can you list the browsers you've tried?


Tried both chrome and safari. Have a feeling you have stopped access as all OK on android phone just issues with ipad which is running on version 12.5.7. Was working great until had to reinstall the app

I’ve just tried that and still getting the same ‘Service not available’ message 

Joining in

Same iOS 12.5.7 same issue on iPads and I have tried multiple gives same error service not available all other Apple devices work fine! Great beta testing!!!

Can I just confirm are you getting this notice when you are at home and connected to the WiFi @sm92?